geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevan Miller <kevan.mil...@gmail.com>
Subject Re: Errors when deploying
Date Wed, 13 May 2009 02:26:35 GMT

On May 12, 2009, at 6:39 PM, nithya.srinivasan@sun.com wrote:

> I am getting these errors when depolying my war.
> Will appreciate any help.
>
> ServerConfig
> 2.1.4
> Build    2009.03.26-16:45:43.658-0400
> Start Time    Tue May 12 15:15:03 PDT 2009
> Up Time    20 minutes 36 seconds
>
> Operating System
> Architecture    sparc
> Name    SunOS
> Version    5.9
> Patch Level    unknown
> Locale    en_US
>
> JVM
> Java Version    1.5.0_01
> Java Vendor    Sun Microsystems Inc.
> Node    minibar/192.18.71.96
> Current Memory Used    86.63 MB
> Most Memory Used    86.63 MB
> Total Memory Allocated    913.38 MB
> Available Processors    4
>
> Exception
> --------------
> java.lang.Exception: Could not load 1/0/com/sun/codemodel/ 
> CodeWriter.class
>       at  
> org.apache.xbean.finder.ClassFinder.readClassDef(ClassFinder.java:726
> )
>       at org.apache.xbean.finder.ClassFinder.<init>(ClassFinder.java: 
> 141)
>       at  
> org.apache.geronimo.jaxws.builder.WARWebServiceFinder.discoverWebServ
> ices(WARWebServiceFinder.java:154)
>       at  
> org.apache.geronimo.jaxws.builder.AdvancedWARWebServiceFinder.discove
> rPOJOWebServices(AdvancedWARWebServiceFinder.java:73)
>       at  
> org.apache.geronimo.jaxws.builder.AdvancedWARWebServiceFinder.discove
> rWebServices(AdvancedWARWebServiceFinder.java:45)
>       at  
> org.apache.geronimo.jaxws.builder.WARWebServiceFinder.discoverWebServ
> ices(WARWebServiceFinder.java:70)
>       at  
> org.apache.geronimo.jaxws.builder.JAXWSServiceBuilder.discoverWebServ
> ices(JAXWSServiceBuilder.java:97)
>       at  
> org.apache.geronimo.jaxws.builder.JAXWSServiceBuilder.findWebServices
> (JAXWSServiceBuilder.java:80)
>       at  
> org.apache.geronimo.web25.deployment.AbstractWebModuleBuilder.basicIn
> itContext(AbstractWebModuleBuilder.java:364)
>       at  
> org.apache.geronimo.tomcat.deployment.TomcatModuleBuilder.initContext
> (TomcatModuleBuilder.java:330)
>       at  
> org.apache.geronimo.j2ee.deployment.SwitchingModuleBuilder.initContex
> t(SwitchingModuleBuilder.java:159)

Hi Nithya,
How are you deploying your app? Is the deploy failing or succeeding?  
Where are you getting this error?

--kevan
Mime
View raw message