geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Russell Collins <Russell.Coll...@mclaneat.com>
Subject RE: Date Problem
Date Wed, 20 May 2009 13:16:25 GMT
Thank you David.  You were absolutely correct.  My client needed to have a reference to the
OpenJPA jar file.  Once I added that, everything worked like a charm!!


Russell Collins
Sr. Software Engineer
McLane Advanced Technology

"Do or do not, there is no try." - Yoda

-----Original Message-----
From: David Jencks [mailto:david_jencks@yahoo.com]
Sent: Wednesday, May 20, 2009 2:10 AM
To: user@geronimo.apache.org
Subject: Re: Date Problem

I found a couple posts on the openjpa lists that talk about this
problem.

The first says that making openjpa classes available to the client
will cause the client to be able to deserialize the dynamic proxy.
The second suggests that if the entity you are sending to the client
is detached then a plain Date not a proxy should be sent.

Raising this again on the openjpa lists might produce more info.

thanks
david jencks

On May 19, 2009, at 9:58 PM, Russell Collins wrote:

> Hello, I am new to OpenJPA and the entire persistence objects so
> bear with me a little.  First of all, I am using Apache Geronimo
> which has OpenJPA version1.2.1 and I am moving from Hibernate (which
> is a pain to try to work in Geronimo).  Everything works fine except
> for Dates and Times.  I have an Embedded class that starts off like
> this:
>
>
> @Embeddable
> public class EntityChange implements Serializable {
>
>
>      private static final long serialVersionUID = 1L;
>
>      @Column(name = "changedate" )
>      @Temporal(DATE)
>      private Date changeDate;
>
>      @Column(name = "changetime")
>      @Temporal(TIME)
>      private Time changeTime;
>
>      @Column(name = "changeuser")
>      private String changeUser;
>
>
> When I try to grab an object with these embedded values I get the
> error:
>
>
>
> java.lang.AssertionError: javax.ejb.EJBException: Unknown Container
> Exception: java.rmi.RemoteException: Cannot read the response from
> the server.  The class for an object being returned is not located
> in this system:; nested exception is:
>            java.lang.ClassNotFoundException:
> org.apache.openjpa.util.java$sql$Date$proxy
>
> I have tried multiple ways with adding and removing @Temporal etc.
> Oh one more thing, this is a MySQL database that I am trying to
> access.  Please give me any help you can.  Thanks.
>
>
> Russell Collins
>

Mime
View raw message