geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Petersson <petersson.pe...@gmail.com>
Subject Re: Strange problem starting G v2.1
Date Sat, 09 May 2009 10:26:26 GMT
David Jencks wrote:
> Hi Peter,
>
> On May 8, 2009, at 6:03 PM, Peter Petersson wrote:
>
>> Donald Woods wrote:
>>
>> Hi Donald, thank you for your swift replay, you will find my reply below
>>> Noticed you extracted the server to /usr/local.  What directory/file 
>>> permissions did you use?  Can the current user create/write/delete 
>>> files and directories?
>> Yes its a bit orthodox (old fashion) ;) but yes, although I have set 
>> permissions for a regular user (my self) on the geronomo dir:s/files, 
>> I start the server as root.
>>>
>>>
>>> Does start/stop work okay if you use the startup.sh/shutdown.sh 
>>> scripts that use the old geronimo.sh shell script instead of gshell?
>> Thats the problem, I start G v2.1 (with ./startup.sh) and afaik It 
>> should (dose) not use gshell, but for some reason (version 2.1.4 of 
>> gshell) somehow gets involved during start up (? Module  1/74) making 
>> the kernel throw a lifecycle exception. Am I missing something here ?
>>
>> I do not know why this is happening but I am inclined to believe I 
>> have made some configuration mistake somewhere that makes gshell 
>> (from my G v2.1.4) kick in and get involved in the G v2.1 startup, 
>> but I can not figger out what or why.
>
> Did the 2.14 server start OK before you started deploying apps to it?

The strange thing is I am starting the 2.1 server and it is the vanilla 
tomcat6-javaee5-2.1 server with nothing added. As you can see below it 
is loading of gshell v2.1.4(!) that fails during start up of G v2.1 and 
this is definitely some kind of mix up. The 2.1.4 server (with apps) 
starts and stops correctly.

Turning on debug I see this just before the server startup failure.
12:00:59,248 DEBUG [MultiParentClassLoader] Unable to clear SoftCache 
field subclassAudits in class class java.io.ObjectInputStream

Don't know the implication of this or if it is related to any of this.

Thank you for suggestions and guesses, anything that brings me closer to 
resolving this is appreciated.

regards
   peter petersson

>
>
> gshell-geronimo is not supposed to be started, just loaded so its 
> classes are available.  I wonder if one of your apps has an "all" 
> scope (that's the default) dependency on something like boilerplate 
> that is then causing the gshell plugins to try to start.  I can't 
> think why you would need a dependency on boilerplate at all but if for 
> some reason you do need it try making it a "classes" scoped dependency
> <import>classes</import>
>
> Hope this guess helps :-)
> david jencks
>
>>
>>
>> Thank you for your help!
>> regards
>>  peter petersson
>>>
>>>
>>> -Donald
>>>
>>>
>>> Peter Petersson wrote:
>>>> Just unpacked and installed G v2.1 
>>>> (geronimo-tomcat6-javaee5-2.1-bin.tar.gz) and G v2.1.4 
>>>> (geronimo-tomcat6-javaee5-2.1.4-bin.tar.gz) on a fresh dev machine 
>>>> at work with Ubuntu 9.04 jaunty and Java 1.5.0_18 to start 
>>>> migrating from v2.1 to v2.1.4.
>>>> After installing some of our apps in G v2.1.4 I decided to shutdown 
>>>> the server and start up G v2.1 but encountered the startup failure 
>>>> shown bellow (trying to start gshell-geronimo/2.1.4).
>>>>
>>>> Suspecting some process still running from the G v2.1.4 assembly 
>>>> (without being able to pinpoint any) I disabled startup scripts and 
>>>> restarted the comp and checked that no java process or geronimo 
>>>> process was running prior to new startup of G v2.1 but still get 
>>>> this error.
>>>>
>>>> Anyone have ideas about what may cause this problem ? What have I 
>>>> forgot about(?) I am fairly sure it's something obvious ;)
>>>>
>>>> I am starting with ./startup.sh (in G v2.1 bin) and don't have any 
>>>> fishy or otherwise suspicious environment var:s set (afaik).
>>>> regards
>>>>  peter petersson
>>>>
>>>> ==> geronimo.log <==
>>>> 20:19:43,943 INFO  [Log4jService] 
>>>> ----------------------------------------------
>>>> 20:19:43,943 INFO  [Log4jService] Started Logging Service
>>>> 20:19:43,943 INFO  [Log4jService] Runtime Information:
>>>> 20:19:43,943 INFO  [Log4jService]   Install Directory = 
>>>> /usr/local/geronimo-tomcat6-javaee5-2.1
>>>> 20:19:43,943 INFO  [Log4jService]   JVM in use = Sun Microsystems 
>>>> Inc. Java 1.5.0_18
>>>>  :
>>>> 20:26:33,914 INFO  [Log4jService]   System property 
>>>> [sun.boot.class.path] = 
>>>> /usr/local/geronimo2/lib/endorsed/yoko-spec-corba-1.0-r615303.jar:/usr/local/geronimo2/lib/endorsed/yoko-rmi-spec-1.0-r615303.jar:/usr/lib/jvm/java-1.5.0-sun-1.5.0.18/jre/lib/rt.jar:/usr/lib/jvm/java-1.5.0-sun-1.5.0.18/jre/lib/i18n.jar:/usr/lib/jvm/java-1.5.0-sun-1.5.0.18/jre/lib/sunrsasign.jar:/usr/lib/jvm/java-1.5.0-sun-1.5.0.18/jre/lib/jsse.jar:/usr/lib/jvm/java-1.5.0-sun-1.5.0.18/jre/lib/jce.jar:/usr/lib/jvm/java-1.5.0-sun-1.5.0.18/jre/lib/charsets.jar:/usr/lib/jvm/java-1.5.0-sun-1.5.0.18/jre/classes

>>>>
>>>> 20:26:33,914 INFO  [Log4jService] 
>>>> ----------------------------------------------
>>>> ==> geronimo.out <==
>>>> Booting Geronimo Kernel (in Java 1.5.0_18)...
>>>> Module  1/74 
>>>> org.apache.geronimo.framework/gshell-geronimo/2.1.4/car              
>>>> Server Startup failed
>>>>
>>>> org.apache.geronimo.kernel.config.LifecycleException: load of 
>>>> org.apache.geronimo.framework/gshell-geronimo/2.1.4/car failed
>>>>    at 
>>>> org.apache.geronimo.kernel.config.SimpleConfigurationManager.loadConfiguration(SimpleConfigurationManager.java:276)

>>>>
>>>>    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>>>>       :
>>>>       :
>>>>
>>
>


Mime
View raw message