Hi Antonio,

† Maven is not necessary in this project.
† The deployment plan of the web project (geronimo-web.xml)† looks like this. But I don't think there is anything special.
---------------------------------------------------------------------------------------------------------------
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<web:web-app xmlns:app="http://geronimo.apache.org/xml/ns/j2ee/application-2.0" xmlns:client="http://geronimo.apache.org/xml/ns/j2ee/application-client-2.0" xmlns:conn="http://geronimo.apache.org/xml/ns/j2ee/connector-1.2" xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.2" xmlns:ejb="http://openejb.apache.org/xml/ns/openejb-jar-2.2" xmlns:name="http://geronimo.apache.org/xml/ns/naming-1.2" xmlns:pers="http://java.sun.com/xml/ns/persistence" xmlns:pkgen="http://openejb.apache.org/xml/ns/pkgen-2.1" xmlns:sec="http://geronimo.apache.org/xml/ns/security-2.0" xmlns:web="http://geronimo.apache.org/xml/ns/j2ee/web-2.0.1">
††† <dep:environment>
††††††† <dep:moduleId>
††††††††††† <dep:groupId>default</dep:groupId>
††††††††††† <dep:artifactId>CalculatorWeb</dep:artifactId>
††††††††††† <dep:version>1.0</dep:version>
††††††††††† <dep:type>car</dep:type>
††††††† </dep:moduleId>
††††††† <dep:dependencies>
††††††††††† <dep:dependency>
††††††††††††††† <dep:groupId>default</dep:groupId>
††††††††††††††† <dep:artifactId>calculator</dep:artifactId>
††††††††††††††† <dep:version>1.0</dep:version>
††††††††††††††† <dep:type>car</dep:type>
††††††††††† </dep:dependency>
††††††† </dep:dependencies>
††† </dep:environment>
††† <web:context-root>/CalculatorWeb</web:context-root>
</web:web-app>
---------------------------------------------------------------------------------------------------------------

If there is still any problem, please let me know.† And please tell me about the detials of the error. Thanks!

Best Regards,
Ying Tang

2009/4/2 Antonio Forniť <sitaronocturnal@gmail.com>

Thank you all very much!!

I've tried to do what you've told me, Ying Tang... but it doesn't work.
Please, is there any xml configuration that I must change. I've done
everything similar to the tutorial you told me, but it doesn't work anyway.

One more thing, I'm not using Maven. Is it necessary?

Thank you very much.

Antonio
--
View this message in context: http://www.nabble.com/Basic-EJB-app-structure-tp22817752s134p22844060.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.