-----Original Message-----
From: JohnD <lists@johndubchak.com>
Reply-to: lists@johndubchak.com
To: user@geronimo.apache.org
Subject: 2.1.3 to 2.1.4 Upgrade Virtual Hosts issue
Date: Sun, 19 Apr 2009 09:15:56 -0500

> Hi,
>
>We have a 2.1.3 instance that is configured with multiple virtual hosts running in production.  Now I'd like to migrate to 2.1.4 >however, when I configure the virtual hosts and start geronimo I am getting the following error:
>
>Module 25/71 org.apache.geronimo.configs/tomcat6/2.1.4/car 2009-04-19 09:01:38,158 ERROR [JAASRealm] 
>Class org.apache.geronimo.security.realm.providers.GeronimoUserPrincipal not found! Class not added. 
>2009-04-19 09:01:38,158 ERROR [JAASRealm] Class org.apache.geronimo.security.realm.providers.GeronimoGroupPrincipal 
>not found! Class not added. started in   .822s
>
>Here is the virtual host gbean definition I am using (I put it right after the  <module >name="org.apache.geronimo.configs/tomcat6/2.1.4/car"> opening XML tag):
>
><gbean >name="org.apache.geronimo.configs/tomcat6/2.1.4/car?ServiceModule=org.apache.geronimo.configs/tomcat6/2.1.4/car,j2eeType=Host,name=TomcatVirtualHost_1" >gbeanInfo="org.apache.geronimo.tomcat.HostGBean">
>       <attribute name="className">org.apache.catalina.core.StandardHost</attribute>
>       <attribute name="initParams">name=www.example.com
>                appBase=
>                workDir=work</attribute>
></gbean>
>
>I did a couple of google searches and didn't turn up anything other than a bug back in 1.x.  What do I need to change in order to >get virtual hosting working correctly under 2.1.4?
>
>Thanks,
>John


Am I the only one experiencing this issue?  Can someone please point me to some documentation that might help me get virtual hosted instances running?

Thanks,
John