geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John <li...@johndubchak.com>
Subject Re: 2.1.3 to 2.1.4 Upgrade Virtual Hosts issue
Date Mon, 27 Apr 2009 03:35:02 GMT
Hi David,

Thanks for your reply.  The only thing I did was download the new 
version of geronimo, untar it, add my virtual hosts that work in 2.1.3, 
change the 2.1.3 to 2.1.4 and start the server.

I have not configured JAAS in Tomcat or modified any other code.  I 
wouldn't have thought the virtual hosts gbean stuff would have changed 
between minor versions either.

John

David Jencks wrote:
> I'm not sure why anything would have changed between 2.1.3 and 2.1.4.
> 
> The message is from tomcat's JAASRealm parseClassNames.  I'm also not 
> sure why this code is getting called at all because we normally use a 
> geronimo realm that uses jacc.  So, I would expect that this message may 
> not indicate that anything has failed.
> 
> Have you explicitly configured a JAASRealm somewhere?  Despite the error 
> message does your app work?
> 
> If you want to investigate further I'd recommend putting a breakpoint at 
> JAASRealm.parseClassNames and trying to figure out why its getting called.  
> 
> It would be great if we had a testsuite app that checked that virtual 
> hosts work in tomcat and jetty.  I'm not quite sure if we could use one 
> deployment plan for both web apps... I think there might be a way to 
> have both container specific configurations in the same plan.
> 
> I'm also not enough of an expert on http to know how to write a test for 
> virtual hosts :-(
> 
> hope this helps
> david jencks
> 
> On Apr 26, 2009, at 8:59 AM, JohnD wrote:
> 
>> -----Original Message-----
>> *From*: JohnD <lists@johndubchak.com 
>> <mailto:JohnD%20%3clists@johndubchak.com%3e>>
>> *Reply-to*: lists@johndubchak.com <mailto:lists@johndubchak.com>
>> *To*: user@geronimo.apache.org <mailto:user@geronimo.apache.org>
>> *Subject*: 2.1.3 to 2.1.4 Upgrade Virtual Hosts issue
>> *Date*: Sun, 19 Apr 2009 09:15:56 -0500
>>
>> > Hi,
>> >
>> >We have a 2.1.3 instance that is configured with multiple virtual 
>> hosts running in production.  Now I'd like to migrate to 2.1.4 
>> >however, when I configure the virtual hosts and start geronimo I am 
>> getting the following error:
>> >
>> >Module 25/71 org.apache.geronimo.configs/tomcat6/2.1.4/car 2009-04-19 09:01:38,158
ERROR [JAASRealm] 
>> >Class org.apache.geronimo.security.realm.providers.GeronimoUserPrincipal not
found! Class not added. 
>> >2009-04-19 09:01:38,158 ERROR [JAASRealm] Class org.apache.geronimo.security.realm.providers.GeronimoGroupPrincipal

>> >not found! Class not added. started in   .822s
>> >
>> >Here is the virtual host gbean definition I am using (I put it right 
>> after the  <module 
>> >name="org.apache.geronimo.configs/tomcat6/2.1.4/car"> opening XML tag):
>> >
>> ><gbean 
>> >name="org.apache.geronimo.configs/tomcat6/2.1.4/car?ServiceModule=org.apache.geronimo.configs/tomcat6/2.1.4/car,j2eeType=Host,name=TomcatVirtualHost_1"

>> >gbeanInfo="org.apache.geronimo.tomcat.HostGBean">
>> >       <attribute 
>> name="className">org.apache.catalina.core.StandardHost</attribute>
>> >       <attribute name="initParams">name=www.example.com 
>> <http://www.eliteswa.com>
>> >                appBase=
>> >                workDir=work</attribute>
>> ></gbean>
>> >
>> >I did a couple of google searches and didn't turn up anything other 
>> than a bug back in 1.x.  What do I need to change in order to >get 
>> virtual hosting working correctly under 2.1.4?
>> >
>> >Thanks,
>> >John
>>
>>
>> Am I the only one experiencing this issue?  Can someone please point 
>> me to some documentation that might help me get virtual hosted 
>> instances running?
>>
>> Thanks,
>> John
> 


Mime
View raw message