geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Petersson <petersson.pe...@gmail.com>
Subject Re: G trunk and maven dependencies question
Date Sun, 12 Apr 2009 12:06:13 GMT
Thanks for the effort David but it did not fix the problem I still get 
this dependency (both in trunk and in my plugin)

        <dependency>
            <groupId>org.apache.geronimo.specs</groupId>
            <artifactId>geronimo-jaspi_1.0_spec</artifactId>
            <version>1.0-20080804.213256-1</version>
            <type>jar</type>
        </dependency>

I still see it in geronimo/server/trunk for example in
geronimo-server/bin/framework/configs/jee-specs/target/resources/META-INF/geronimo-plugin.xml

Doing a local server/trunk build with a clean .m2 repository dose anyone 
else see this ?

Looking in the snapshot repository (and local .m2) there is only the 
1.0-SNAPSHOT version but anyway the car-maven-plugin seems to find this 
dated version dependency from (somewhere ?) causing my plugin build to 
fail if I don't build geronimo/server/trunk first.
Taking a look in local .m2 repository after building trunk I can still 
only see the 1.0-SNAPSHOT and my derby plugin builds fine and there are 
no trace of the dated version in my project.

Although this is only a guess I think there may be something buried deep 
in the car-maven-plugin (2.2-snapshot) dependency tree that causes this 
when there are no local artifacts available. I am trying to track down 
this problem but I am starting to miss out on new ideas, is there any 
good way of tracking this, any suggestions ?  

I also see this dated versions in the geronimo-plugin.xml file in trunk
        <dependency>
            <groupId>org.apache.geronimo.specs</groupId>
            <artifactId>geronimo-concurrent_1.0_spec</artifactId>
            <version>1.0-20080804.214102-1</version>
            <type>jar</type>
        </dependency>
        <dependency>
            <groupId>org.apache.geronimo.specs</groupId>
            <artifactId>geronimo-servlet_3.0_spec</artifactId>
            <version>1.0-EA-20080711.180136-1</version>
            <type>jar</type>
        </dependency>

Included attachments are output from "mvn dependency:tree" and the 
failing "mvn install" when trying to build the plugin from a clean .m2 
repository.

thanks
    peter petersson 

David Jencks skrev:
> For some reason I'm not seeing this locally, perhaps due to the local 
> changes in my build.  I took a heavy-handed approach of just deleting 
> the timestamped artifacts from the snapshot repo.  Please let us know 
> if this does not fix the problem.
>
> thanks
> david jencks
>
> On Apr 10, 2009, at 4:11 AM, Peter Petersson wrote:
>
>> Oh sry my mistake I pointed to the wrong file(s) the dependencies.xml 
>> files don't have the version tag.
>>
>> I rebuilt from a empty local repository and did a mvn clean install 
>> on gernimo/server/trunk (svn rev 763909) and here is a couple of 
>> places where the dated version of geronimo-jaspi_1.0_spec shows up
>>
>> geronimo-server/bin/framework/configs/jee-specs/target/resources/META-INF/geronimo-plugin.xml

>> (and plan.xml) have
>>       <dependency>
>>           <groupId>org.apache.geronimo.specs</groupId>
>>           <artifactId>geronimo-jaspi_1.0_spec</artifactId>
>>           <version>1.0-20080804.213256-1</version>
>>           <type>jar</type>
>>       </dependency>
>>
>> Also for example monitoring/mconsole-jetty-server 
>> .../target/assembly/repository/... geronimo-plugin.xml and plan.xml 
>> and more.
>> hmm the cmp generates thous files, question is why (and where) dose 
>> it got hold of the 1.0-20080804.213256-1 version?
>> mvn --version gives
>> Maven version: 2.0.9
>> Java version: 1.5.0_16
>> OS name: "linux" version: "2.6.27-11-generic" arch: "amd64" Family: 
>> "unix"
>>
>> Its not a big thing as everything builds fine after building 
>> gernonimo/server/trunk but It would be nice to find out whats going 
>> on and maybe fix the problem as it would be good to be able to do 
>> plugin/assembly development/builds without also having to check out 
>> and build the server.
>> regards
>>   peter petersson
>>
>> David Jencks skrev:
>>> Where exactly do you see the file with the dated version?  I've 
>>> looked around in my build and don't see anything obvious.
>>> BTW this problem sounds familiar but I don't remember yet when I ran 
>>> into it...
>>>
>>> thanks
>>> david jencks
>>> On Apr 9, 2009, at 4:36 PM, Peter Petersson wrote:
>>>
>>>> I am building some geronimo plugins "against" G v2.2 (trunk) and I 
>>>> am getting a strange unresolved maven dependency issue against a 
>>>> dated version of the   geronimo-jaspi_1.0_spec (see below) when I 
>>>> build from a clean .m2 repository.
>>>>
>>>> AFAICT the geronimo-jaspi_1.0_spec version should be 1.0-SNAPSHOT 
>>>> (as declared in geronimo server root pom). I have "Geronimo Server 
>>>> Private Repository" and "Apache Snapshots Repository" as repository 
>>>> settings in my project (should be enough to build gplugins?) but 
>>>> only when I first build Geronimo server trunk will my derby plugin 
>>>> build without error.
>>>> Looking at the generated dependency versions for 
>>>> geronimo-jaspi_1.0_spec in my built geronimo server trunk I also 
>>>> see a dated version (1.0-20080804.213256-1) of the spec in 
>>>> dependecies.xml and not as I would expect the 1.0-SNAPSHOT version.
>>>>
>>>> Do I have some misconfiguration or is this a (by me) unforeseen 
>>>> maven snapshot behavior?
>>>> regards
>>>> peter petersson
>>>>
>>>> [INFO] [car:verify-no-dependency-change]
>>>> Downloading: 
>>>> http://svn.apache.org/repos/asf/geronimo/server/trunk/repository/org/tranql/tranql-connector-derby-embed-local/1.4/tranql-connector-derby-embed-local-1.4.rar

>>>>
>>>> Downloading: 
>>>> http://repo1.maven.org/maven2/org/tranql/tranql-connector-derby-embed-local/1.4/tranql-connector-derby-embed-local-1.4.rar

>>>>
>>>> 86K downloaded
>>>> [INFO] [car:package]
>>>> [INFO] Packaging module configuration: 
>>>> /usr/local/proj/geronimo-liferay/plugins/connectors/liferay-database-derby/target/resources/META-INF/plan.xml

>>>>
>>>> [INFO]  GBean references are not using proxies
>>>> [INFO]  ClassLoading behaviour has changed.  The Original 
>>>> Classloading mode is in effect.  If you are experiencing a problem
>>>> you can change the behaviour by specifying 
>>>> -DXorg.apache.geronimo.kernel.config.MPCLSearchOption= property.  
>>>> Specify
>>>> ="safe" to revert to the original behaviour.  This is a temporary 
>>>> change until we decide whether or not to make it
>>>> permanent for the 2.0 release
>>>> [ERROR] Error while starting; GBean is now in the FAILED state: 
>>>> abstractName="org.apache.geronimo.framework/jee-specs/2.2-SNAPSHOT/car?configurationName=org.apache.geronimo.framework/jee-specs/2.2-SNAPSHOT/car"

>>>>
>>>> org.apache.geronimo.kernel.repository.MissingDependencyException: 
>>>> Missing dependency: 
>>>> org.apache.geronimo.specs/geronimo-jaspi_1.0_spec/1.0-20080804.213256-1/jar

>>>>
>>>>  org.apache.geronimo.kernel.config.ConfigurationResolver.resolve(ConfigurationResolver.java:113)

>>>>
>>>>  org.apache.geronimo.kernel.config.Configuration.buildClassPath(Configuration.java:410)

>>>>
>>>>  org.apache.geronimo.kernel.config.Configuration.createConfigurationClasssLoader(Configuration.java:334)

>>>>
>>>>  org.apache.geronimo.kernel.config.Configuration.<init>(Configuration.java:276)

>>>>
>>>>   :
>>>>   :
>>>
>>
>>
>



Mime
View raw message