geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick McGuire <rick...@gmail.com>
Subject Re: Javamail build
Date Tue, 07 Apr 2009 10:27:01 GMT
Glenn Macgregor wrote:
>
> Hi All,
>
>  
>
> The maven pom.xml for javamail defines a jdk range 1.5-1.6 exclusive. 
> I have 1.6.0_13 and it compiles fine.
>
>  
>
> Are there known issues using a jdk > 1.5?
>
>  
>
> Thanks
>
>  
>
>  Glenn
>
I  believe that is there to ensure the javamail code remains compatible 
with a java 1.4.2 runtime.  That places a restriction on the features 
that can be used in the code (e.g, no generics).

Rick

Mime
View raw message