geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From JohnD <li...@johndubchak.com>
Subject Re: 2.1.3 to 2.1.4 Upgrade Virtual Hosts issue
Date Thu, 30 Apr 2009 11:16:30 GMT
Yes, I am able to access the geronimo console and can also deploy an app
to the virtual host.  Can I just ignore this error then?


-----Original Message-----
From: Rex Wang <rwonly@gmail.com>
Reply-to: user@geronimo.apache.org
To: user@geronimo.apache.org
Subject: Re: 2.1.3 to 2.1.4 Upgrade Virtual Hosts issue
Date: Thu, 30 Apr 2009 17:51:01 +0800

I got the JAASRealm errors too, but it won't impact the virtual host
feature.
I will take a look at the security realm issue further.

John, can you deploy the web app to the real host ? can you access the
web console from the virtual host after deploy a web app with the <host>
set in plan?

Rex

2009/4/29 John <lists@johndubchak.com>
        chi runhua wrote:
        
                Hi, I just tried both on 2.1.3 and 2.1.4 and got the
                same error that JohnD mentioned above. (following the
                instruction at
                http://cwiki.apache.org/GMOxDOC21/configuring-virtual-hosts-in-geronimo-tomcat.html
)
                
                jeff@jeff:~/Geronimo/2.1.3/bin$ ./geronimo.sh run
                Using GERONIMO_BASE:   /home/jeff/Geronimo/2.1.3
                Using GERONIMO_HOME:   /home/jeff/Geronimo/2.1.3
                Using GERONIMO_TMPDIR: var/temp
                Using JRE_HOME:        /opt/ibm/java-i386-60/jre
                Booting Geronimo Kernel (in Java 1.6.0)...
                Starting Geronimo Application Server v2.1.3
                [***************                         ]  39%   9s
                Starting org.apache.ger...12:35:02,891 ERROR [JAASRealm]
                Class
                org.apache.geronimo.security.realm.providers.GeronimoUserPrincipal not found!
Class not added.
                12:35:02,891 ERROR [JAASRealm] Class
                org.apache.geronimo.security.realm.providers.GeronimoGroupPrincipal not found!
Class not added.
                12:35:02,893 ERROR [JAASRealm] Class
                org.apache.geronimo.security.realm.providers.GeronimoUserPrincipal not found!
Class not added.
                12:35:02,893 ERROR [JAASRealm] Class
                org.apache.geronimo.security.realm.providers.GeronimoGroupPrincipal not found!
Class not added.
                [****************************************] 100%  21s
                Startup complete
                
                
                But the virtual host feature seems fine.
                
                
                Jeff C
        
        
        
        
        In my case, I am not able to deploy a Webapp to the virtual
        host.  I'm outside our environment right now and can't test it
        again to get the error message.  I will try again later and
        repost with a copy of the error message.
        
        John


Mime
View raw message