geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevan Miller <kevan.mil...@gmail.com>
Subject Re: Geronimo won't start (was "First time user can't start geronimo")
Date Sun, 29 Mar 2009 17:01:24 GMT

On Mar 29, 2009, at 12:21 PM, cknell@onebox.com wrote:

> I apologize for changing the subject line, but when I replied to the  
> reply shown below, the apache mail server rejected it as spam.
>
> Now, on to my problem.
>
> I have captured the console output to a text file. In my original  
> post, I quoted the first error message. Here it is again:
>
>
> *********
>
> 39%  13s Starting org.apache.ger...11:50:34,848 ERROR  
> [Http11Protocol] Error initializing endpoint
> java.net.BindException: Address already in use: JVM_Bind /0.0.0.0:8080
> 	at org.apache.tomcat.util.net.JIoEndpoint.init(JIoEndpoint.java:504)
> 	at org.apache.coyote.http11.Http11Protocol.init(Http11Protocol.java: 
> 176)
> 	at  
> org.apache.catalina.connector.Connector.initialize(Connector.java: 
> 1058)

Sorry to restate the obvious -- you're absolutely sure that nobody's  
using port 8080?

Did you make any configuration changes to Geronimo? What version of  
Geronimo are you using?

You can edit var/config/config-substitutions.properties to use a  
different port number.

Either:

HTTPPort=<new-port-number>

or, to change all port numbers (e.g. increment by 10):

PortOffset=10

One final thing, in case there's something strange in your network  
config, is to change

ServerHostname=0.0.0.0
to
ServerHostname=127.0.0.1

--kevan
Mime
View raw message