geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hearty <heartyraph...@gmail.com>
Subject Re: Issues facing when connecting with Oracle10g
Date Fri, 13 Mar 2009 07:09:53 GMT

I am not using any oracle specific wrapper for the db pool.
I have used admin console for configuring the db pool. Since admin console
does not provide a way
to set the property for autocommit, I have modified ra.xml manually.

I have tried one more option by deploying the dbpool using deploy command
deploy
%GERONIMO_HOME%\repository\org\tranql\tranql-connector-ra\1.4\tranql-connector-ra-1.4.rar
..\fpconfig\oracle10g-deployment-plan.xml

oracle10g-deployment-plan is as follows


<?xml version="1.0" encoding="UTF-8"?>
<connector
	xmlns="http://geronimo.apache.org/xml/ns/j2ee/connector-1.2">
	<dep:environment
		xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.2">
		<dep:moduleId>
			<dep:groupId>console.dbpool</dep:groupId>
			<dep:artifactId>fpdbpool</dep:artifactId>
			<dep:version>1.0</dep:version>
			<dep:type>rar</dep:type>
		</dep:moduleId>
		<dep:dependencies>
			<dep:dependency>
				<dep:groupId>com.telelogic.focalpoint.lib</dep:groupId>
				<dep:artifactId>ojdbc14</dep:artifactId>
				<dep:version>10.2.0.1.0</dep:version>
				<dep:type>jar</dep:type>
			</dep:dependency>
		</dep:dependencies>
	</dep:environment>
	<resourceadapter>
		<outbound-resourceadapter>
			<connection-definition>
				<connectionfactory-interface>
					javax.sql.DataSource
				</connectionfactory-interface>
				<connectiondefinition-instance>
					<name>fpdbpool</name>
					<config-property-setting name="Password">
						focalpoint
					</config-property-setting>
					<config-property-setting name="Driver">
						oracle.jdbc.driver.OracleDriver
					</config-property-setting>
					<config-property-setting name="UserName">
						mobile
					</config-property-setting>
					<config-property-setting name="ConnectionURL">
						jdbc:oracle:thin:@192.168.133.96:1521:orcl
					</config-property-setting>
					<config-property-setting
name="CommitBeforeAutocommit">true</config-property-setting>
					
					<connectionmanager>
						<local-transaction />
						<single-pool>
							<max-size>10</max-size>
							<min-size>10</min-size>
							<blocking-timeout-milliseconds>
								60000
							</blocking-timeout-milliseconds>
							<idle-timeout-minutes>
								10
							</idle-timeout-minutes>
							<match-one />
						</single-pool>
					</connectionmanager>
				</connectiondefinition-instance>
			</connection-definition>
		</outbound-resourceadapter>
	</resourceadapter>
</connector>


But I've observed even I've specified "CommitBeforeAutocommit" as true,
ra.xml contains the value of "CommitBeforeAutocommit" as false. I am using
"Oracle Thin" as the Database Type.

I am not using any specific tranql wrapper for oracle. I am using
tranql-connector-ra-1.4.rar which I found with
repository\org\tranql\tranql-connector-ra\1.4

Please let me know if I am doing some thing wrong. Is there documentation
(with sample code) for creating tranql oracle specific wrapper for the db
pool.

Can I rely on the admin console alone for deploying the database pool for
oracle 10g?


djencks wrote:
> 
> Its difficult to do more than guess without more information on what  
> you have deployed.
> 
> You should be using one of the tranql oracle specific wrappers for  
> your db pool.  This should take care of the commit-before-autocommit  
> problem caused by oracle jdbc spec non-compliance.  If you aren't  
> using an oracle specific wrapper you do need to set the commit before  
> autocommit property to true, but you should do it in your pool  
> deployment plan, not by modifying the ra.xml.
> 
> At a minimum I think we'd need to know which tranql wrapper you are  
> using and to see the deployment plan for it.
> 
> thanks
> david jencks
> 
> On Mar 12, 2009, at 6:19 AM, Hearty wrote:
> 
>>
>> When I have configured database pool with oracle10g and running  
>> against the
>> apache geronimo v2.1, I am getting some unusual errors where as when  
>> I've
>> tried with tomcat5.5 it is working smoothly.
>> Oracle driver I've used is ojdbc14-10.2.0.1.0.jar.
>>
>> The following is the error message I am getting. Also I am uploading  
>> the
>> error log since the error log is a big file
>> http://www.nabble.com/file/p22476155/errorLog.txt errorLog.txt
>> I have modified ra.xml with the following entry
>> <config-property>
>>                    <description>
>>                        Flag indicating whether the Driver requires a  
>> commit
>> to be performed
>>                        before enabling auto-commit on a Connection.  
>> This
>> should be set to false for
>>                        compliant drivers to avoid an extraneous  
>> commit to
>> the database.
>>                    </description>
>>
>> <config-property-name>CommitBeforeAutocommit</config-property-name>
>>
>> <config-property-type>java.lang.Boolean</config-property-type>
>>                    <config-property-value>true</config-property-value>
>>                </config-property>
>> The default value was false
>>
>> I am struggling with this issue for more than one week.
>>
>> Any help is highly appreciated. I am very new to apache geronimo.  
>> Please let
>> me know if I've missed out any entries.
>>
>> -- 
>> View this message in context:
>> http://www.nabble.com/Issues-facing-when-connecting-with-Oracle10g-tp22476155s134p22476155.html
>> Sent from the Apache Geronimo - Users mailing list archive at  
>> Nabble.com.
>>
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Issues-facing-when-connecting-with-Oracle10g-tp22476155s134p22491260.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message