geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kaupo <kpar...@gmail.com>
Subject Re: jndi datasource access problem
Date Tue, 03 Mar 2009 09:07:41 GMT



Jack Cai wrote:
> 
> 2009/3/3 Kaupo <kparmas@gmail.com>
> 
>>
>>
>> Jack Cai wrote:
>> >
>> > Are you runing this piece of code in the server container or in a
>> > standalone
>> > Web service client? Looks like you are running in the client. You can't
>> > access the server context (resources) in the standalone client.
>> >
>> This code was in the same server. I'm using it in my UserDao, for user
>> authentication. It just doesn't want to work when I try using basic
>> authentication on my webservice (that is running in the same server)
>> Maybe
>> the axis2 engine used in geronimo automatically somehow makes my
>> webservice
>> a standalone client?
>>
> 
> No, that should not happen. Maybe it's configuration problem. You can see
> the usage information of your datasource in admin console (in "Database
> Pools" page, click "Usage" link of your datasource".
> 
> Are you able to run the code successfully with the global JNDI name now?
> 
> -Jack
> 
> 

I started by using the admin consoles "Usage" description, but that didn't
work when I authenticated through my webservice.

The global JNDI name works the way I described it in my previous post.

-Kaupo

-- 
View this message in context: http://www.nabble.com/jndi-datasource-access-problem-tp22290284s134p22304879.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message