geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: Starting from framework
Date Thu, 19 Mar 2009 23:35:04 GMT

On Mar 19, 2009, at 3:46 PM, Derek Potts wrote:

>
>
>
> djencks wrote:
>>
>>
>> very roughly speaking you run
>>
>> ./bin/gsh deploy/list-modules
>>
>> pick the geronimo plugin repository you want
>>
>> (gshell will list the available plugins, including the jetty6 plugin
>> and you probably want the jetty6-deployer plugin too and maybe even
>> the console-jetty)
>> pick the ones you want by number
>>
>> they will get installed.
>>
>> I'm afraid I haven't personally checked what happens with released
>> versions of g.  There's supposed to be a plugin catalog configured  
>> for
>> each version and the location inserted into g. before release, but
>> since I'm always working with trunk I rely on my local maven repo.  I
>> do know I've seen commits for these plugin catalogs.... and you can
>> tell geronimo about them if they aren't already configured.
>>
>> hope this helps
>> david jencks
>>
>>
>
> When I run deploy/list-modules, I only get a list of 14. If I  
> understand you
> correctly, this is due to a lack of a repository configuration? How  
> do I set
> one up?

I gave you some bad information.  I just tried with a copy of 2.1.4- 
SNAPSHOT of some age I have here....

1. edit var/config/config.xml to look like this:

             <attribute name="userRepositories">~/.m2/repository,http://geronimo.apache.org/plugins/geronimo-2.1.4

</attribute>


2. The correct gshell command is

deploy/list-plugins

After the above edit you should get a choice of repos -- the non-local  
one should have the 2.1.4 plugins.

The list-modules command just shows what is installed in the server  
already.


However I'm afraid there may be bugs in the 2.1.4 server.  When I try  
to install jetty6 (#70 in the listing I got) I got a message about a  
2.1.3-only plugin (unidentified).  When I tried to install plugin 1  
(jetty console) a lot got downloaded but there was a problem  
apparently due to a missing version for

  org.apache.geronimo.modules/geronimo-jetty6//jar

I checked with local snapshot plugins in trunk and installing the  
console onto the framework using plugins works fine.

I guess we should try to figure out what's wrong in 2.1.4 before the  
release is final....

thanks
david jencks

>
> -- 
> View this message in context: http://www.nabble.com/Starting-from-framework-tp22571384s134p22610568.html
> Sent from the Apache Geronimo - Users mailing list archive at  
> Nabble.com.
>


Mime
View raw message