geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pringler <pring...@gmx.net>
Subject Re: Unable to resolve resource reference 'jdbc/MySQLConnectionPool' (Could not find resource 'MySQLConnectionPool'
Date Thu, 05 Feb 2009 08:28:11 GMT

I found the solution, 

im my case the geronimo-application.xml was not placed in the right folder
of the EAR project, it must be placed in the META-INF folder.
So this was the problem in my case.

But I get the hints that it could be a bug from the geronimo version 2.1,
that the server gets problems with the jdbc/ so i tried before the newer
version 2.1.3 where this bug is fixed.



Pringler wrote:
> 
> Hello Community, I'm new on this forum and hope to find help for my
> following error.
> 
> I've tried a lot of searching about the following error, but have nothing
> found.
> 
> Unable to resolve resource reference 'jdbc/MySQLConnectionPool' (Could not
> find resource 'MySQLConnectionPool'.  Perhaps it has not yet been
> configured, or your application does not have a dependency declared for
> that resource module?
> Search conducted in current module and dependencies:
> [ALL: org.apache.geronimo.configs/tomcat6/2.1/car]
> [ALL: default/Application_ID/1233570414144/car]
> [ALL: org.apache.geronimo.configs/openjpa//car]
> [CLASSES: org.apache.geronimo.configs/openejb//car]
> [ALL: org.apache.geronimo.configs/axis//car]
> [ALL: org.apache.geronimo.configs/axis2//car]
> [ALL: org.apache.geronimo.configs/j2ee-corba-yoko//car]
> )
> org.apache.geronimo.common.DeploymentException: Unable to resolve resource
> reference 'jdbc/MySQLConnectionPool' (Could not find resource
> 'MySQLConnectionPool'.  Perhaps it has not yet been configured, or your
> application does not have a dependency declared for that resource module?
> Search conducted in current module and dependencies:
> [ALL: org.apache.geronimo.configs/tomcat6/2.1/car]
> [ALL: default/Application_ID/1233570414144/car]
> [ALL: org.apache.geronimo.configs/openjpa//car]
> [CLASSES: org.apache.geronimo.configs/openejb//car]
> [ALL: org.apache.geronimo.configs/axis//car]
> [ALL: org.apache.geronimo.configs/axis2//car]
> [ALL: org.apache.geronimo.configs/j2ee-corba-yoko//car]
> )
> 	at
> org.apache.geronimo.connector.deployment.ResourceRefBuilder.buildNaming(ResourceRefBuilder.java:207)
> 	at
> org.apache.geronimo.j2ee.deployment.NamingBuilderCollection.buildNaming(NamingBuilderCollection.java:53)
> 	at
> org.apache.geronimo.web25.deployment.AbstractWebModuleBuilder.configureBasicWebModuleAttributes(AbstractWebModuleBuilder.java:842)
> 	at
> org.apache.geronimo.tomcat.deployment.TomcatModuleBuilder.addGBeans(TomcatModuleBuilder.java:343)
> 	at
> org.apache.geronimo.j2ee.deployment.SwitchingModuleBuilder.addGBeans(SwitchingModuleBuilder.java:165)
> 	at
> org.apache.geronimo.j2ee.deployment.EARConfigBuilder.buildConfiguration(EARConfigBuilder.java:647)
> 	at org.apache.geronimo.deployment.Deployer.deploy(Deployer.java:254)
> 	at org.apache.geronimo.deployment.Deployer.deploy(Deployer.java:133)
> 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> 	at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
> 	at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
> 	at java.lang.reflect.Method.invoke(Method.java:585)
> 	at
> org.apache.geronimo.gbean.runtime.ReflectionMethodInvoker.invoke(ReflectionMethodInvoker.java:34)
> 	at
> org.apache.geronimo.gbean.runtime.GBeanOperation.invoke(GBeanOperation.java:124)
> 	at
> org.apache.geronimo.gbean.runtime.GBeanInstance.invoke(GBeanInstance.java:867)
> 	at
> org.apache.geronimo.kernel.basic.BasicKernel.invoke(BasicKernel.java:239)
> 	at
> org.apache.geronimo.deployment.plugin.local.AbstractDeployCommand.doDeploy(AbstractDeployCommand.java:116)
> 	at
> org.apache.geronimo.deployment.plugin.local.DistributeCommand.run(DistributeCommand.java:61)
> 	at java.lang.Thread.run(Thread.java:595)
> 
> Ok the message for me says, that there are some problems with the
> datasource I've created and the reference to the datasource in my
> application. 
> 
> But the application in an earlier version already worked with the geronimo
> server. The only changing I did is, that I changed the build process and
> do it now with maven and a changed the IDE to Rational Application
> Developer 7.5, from there I selected my EAR Project and choose Export EAR
> File....
> Earlier versions of my application work very well without problems, i also
> compared the working EAR File with the new one, but found no differences.
> 
> The geronimo Server Version is: 2.1 running on a Linux CentOS.
> 
> Thx  a lot for your help.
> Greeting Pringler
> 
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Unable-to-resolve-resource-reference-%27jdbc-MySQLConnectionPool%27-%28Could-not-find-resource-%27MySQLConnectionPool%27-tp21787560s134p21847164.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message