Thank you Peter.

In the firts time i supoussed that is a problem with the uddi service beacause always stoped in this point but in the feature. didn't stop here stops before star the tomcat container. I used to check the open ports before start the server and any port had already in use.

I think is a lack issue when Geronimo tries to find or bind a network service or resource, but i can't isolated the issue beacuase Geronimo not sends any exception, only waits.

Do you are using 8.04 o 8.10 Ubuntu?

Regards

2009/1/5 Peter Petersson <petersson.peter@gmail.com>
Hi Luis

I am using Geronimo 2.1.x on a Ubuntu server and have seen this behavior a couple of times.

In my case the startup delay problem you describe has occurred during a re-start of Geronimo and in my case. By checking the <geronimo home>/var/log/geronimo.out file I have found the following module to be the one taken time to start

Module 18/80 org.apache.geronimo.configs/uddi-tomcat/2.1/car                     started in  3:01.119s


In my case the problem has been related to a prior "misbehavior" of a web service application (during shutdown of Geronimo) and the delay is probably related to a port binding issue. Apart from the somewhat alarming startup delay I have not noticed any following sub sequential problem with the running Geronimo server or any deployed web service.

If you hit this problem frequently maybe you can find out if you have a port issue by checking your systems used ports with "netstat -lp" (prior to start/restart of Geronimo) against the ports Geronimo allocates. Ports used by Geronimo is listed in the var/log/geronimo.out file.

I have only seen this a problem a few times during a relatively long time and some Geronimo restarts so I have not investigated the issue any future but maybe this information will point you in the right direction. If needed maybe someone else can fill in the blanks ;).

regards
 Peter Petersson


Luis OrtÝz Silva wrote:
Hi:

I'am getting a big startup issue with mi Geronimo 2.1.3 in Ubuntu Server 8.04 kernel 2.6.24-22-server . It takes 4 minutes to start. I start with thi verbose options. But after this message:

"17:11:53,456 INFO  [SystemProperties] Setting Property=org.apache.catalina.STRICT_SERVLET_COMPLIANCE to Value=true

Geronimos stops the startup process and delays about 4 minutes in continue.

I analized the iptables rules, disable the IPv6 capabilities (beacuse Geronimo always binds to an INET6 port), apparmor is desabled, but the problem persist in the time. I reproduced the same error in my laptop, and always did the same.

If anyone knows how to solve this issue i apreciate a lot, beacuse i need to put in productive mode this server.