geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: Geronimo Deployment Error
Date Wed, 14 Jan 2009 19:46:54 GMT
Does your code start a thread that then gets to the stack trace  
shown?  I don't think the java:comp jndi context is available in any  
threads you create.  One solution would be to use the global jndi  
bindings for the lookups:

http://cwiki.apache.org/GMOxDOC21/jndi.html

(I can't find this documentation in the 2.2 docs)

Hope this helps.  I'm not sure how this would have worked in g. 1.x or  
why it would work the first time you start the server.

david jencks

On Jan 14, 2009, at 6:21 AM, VijayR wrote:

>
> Hello,
>
> I have a Java application which uses the DB Database Pools and JMS
> Resources. We were using Geronimo v1.1.1 before moving over to  
> v2.1.3. We
> have made all the changes required to move over to v2.1.3 (as listed  
> here -
> http://cwiki.apache.org/GMOxDOC21/deployment-descr...r-going-from-g-11-to-g-21.html)

> .
> We don't know whether any code in Java has to be changed or not?
>
> After deploying the JDBC resources and the JMS resources, I deploy  
> the EAR.
> Deployment works fine and the application works the very first time.  
> But if
> I restart the Geronimo server, I get the following error -
>
>
>
>    Module 67/71 org.apache.geronimo.plugins/mconsole-ds/2.1.3/car
>    started in .328s
>    Module 68/71 org.apache.geronimo.plugins/mconsole-tomcat/2.1.3/car
>    started in 1.172s
>    Module 69/71 console.dbpool/LTC/1.0/rar
>    started in .532s
>    Module 70/71 VISE/HL7/1.0/rar
>    started in 1.219s
>    Module 71/71 VISE/VISE/1.0/car
>    12 01 2009 18:19:39 INFO ltc.vise.hl7.gbean.OracleAQProxy Line  
> num: 93
> Starting
>    12 01 2009 18:19:39 INFO ltc.vise.hl7.gbean.OracleAQListener Line  
> num:
> 85 Starting Queues for: D1106
>    12 01 2009 18:19:44 ERROR ltc.vise.hl7.gbean.OracleAQListener  
> Line num:
> 139 Opening JMS Queues
>    java.lang.NullPointerException: You have accessed the java:comp  
> jndi
> context on a thread that has not initialized it
> at
> org 
> .apache 
> .geronimo 
> .gjndi.JavaCompContextGBean.getContext(JavaCompContextGBean.java:34)
>    at
> org 
> .apache 
> .xbean.naming.context.ContextFlyweight.lookup(ContextFlyweight.java: 
> 44)
>    at
> org 
> .apache 
> .xbean 
> .naming 
> .context 
> .ContextFederation.getFederatedBinding(ContextFederation.java:71)
>    at
> org 
> .apache 
> .xbean 
> .naming 
> .context 
> .AbstractFederatedContext.getBinding(AbstractFederatedContext.java:63)
>    at
> org 
> .apache 
> .xbean.naming.context.AbstractContext.lookup(AbstractContext.java:135)
>    at
> org 
> .apache 
> .xbean.naming.context.AbstractContext.lookup(AbstractContext.java:617)
>    at
> org 
> .apache 
> .xbean.naming.context.AbstractContext.lookup(AbstractContext.java:158)
>    at
> org 
> .apache 
> .xbean.naming.context.AbstractContext.lookup(AbstractContext.java:603)
>    at javax.naming.InitialContext.lookup(InitialContext.java:392)
>    at oracle.jms.EmulatedXAHandler.<init>(EmulatedXAHandler.java:69)
>    at oracle.jms.AQjmsSession.<init>(AQjmsSession.java:378)
>    at oracle.jms.AQjmsConnection.createSession(AQjmsConnection.java: 
> 1132)
>    at ltc.vise.hl7.gbean.OracleAQListener.run(OracleAQListener.java: 
> 129)
>    12 01 2009 18:19:47 INFO ltc.vise.utils.Initialization Line num: 58
> Successfully retrieved service
>    12 01 2009 18:19:49 INFO
> ltc.vise.hl7.www.servlet.VISEServletContextListener Line num: 67  
> Servlet
> context initialized, creating timers
>    12 01 2009 18:19:55 INFO ltc.vise.utils.Initialization Line num: 58
> Successfully retrieved service
>    12 01 2009 18:19:55 INFO ltc.vise.hl7.ejb.MailboxReaderBean Line  
> num:
> 278 Timer created at Mon Jan 12 18:19:55 GMT+05:30 2009 with a  
> timeout:
> 60000 and withinfo: KIMAD01-510
>    12 01 2009 18:19:55 INFO ltc.vise.hl7.ejb.MailboxReaderBean Line  
> num:
> 278 Timer created at Mon Jan 12 18:19:55 GMT+05:30 2009 with a  
> timeout:
> 60000 and withinfo: 507-518
>    started in 21.153s
>    Startup completed in 1:55.250s seconds
>    Listening on Ports:
>    1050 127.0.0.1 CORBA Naming Service
>    1099 0.0.0.0 RMI Naming
>
> I have googled the error but could not find any resolution. Any ideas
> please?
>
> Regards,
> Vijay.
>
> -- 
> View this message in context: http://www.nabble.com/Geronimo-Deployment-Error-tp21456910s134p21456910.html
> Sent from the Apache Geronimo - Users mailing list archive at  
> Nabble.com.
>


Mime
View raw message