geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim McConnell <>
Subject Re: Problem adding Geronimo server 2.1.3 Runtime to eclipse
Date Mon, 26 Jan 2009 15:17:27 GMT
HI Edwin, the v1.1 and v2.x versions of the GEP cannot co-exist in the manner 
that you are attempting. What I do, and what I recommend that you do, is to use 
two separate Eclipse installations: one for your Geronimo v1.1 runtime 
environment using the GEP 1.1, and another for your v2.x runtime environment 
using the latest 2.1.3 GEP. Obviously, this is not the most elegant solution, but 
we decided to not support the 1.1 runtimes with the GEP 2.x versions due to time 
constraints when converting from EMF to JAXB......

EdCodd wrote:
> I have an eclipse IDE installation.  I had Apache Geronimo v1.1 and v2.0
> runtime environments added.  I could only add a v2.1 runtime environment
> manually by downloading GEP and adding the features and plugins to the
> eclipse \features and \plugins folders.  I couldn't find another way to add
> the v2.1.  But after adding all of the plugins needed for v2.1, there seems
> to be something wrong with the v1.1 runtime in eclipse.   Under the eclipse
> server view, the v1.1 RE still appears above the v2.0 and the new v2.1
> listing, but there is a red square to the left of the v1.1 listing.  It
> seems that after adding the v2.1, the v1.1 no longer works.  
> Does anyone know what I am doing wrong or anyway around this problem?    

Tim McConnell

View raw message