geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Petersson <petersson.pe...@gmail.com>
Subject Re: Startup time delay in Ubuntu server
Date Wed, 07 Jan 2009 00:19:45 GMT
Hi Luis

Have you found out if it is the uddi module that takes time to start ?

Take a look in your <geronimo home>/var/log/geronimo.out file and look 
for the "startup timing" lines like this one

Module 18/80 
org.apache.geronimo.configs/uddi-tomcat/2.1/car                     
started in  3:01.119s  

In my case this module normally starts in a five seconds but as you can 
see here it takes about 3 minutes to start.

If you see a similar startup time when you look in your log file I think 
the dns timeout problem David is hinting at could be what causing the 
problem.

If it is the uddi module that takes time to start dose your Geronimo 
servers (server and laptop) reside on a network with a local managed dns 
server (other than resolvconf)? If this is the case as in my case maybe 
David is also right about the problem being caused by some dns 
configuration issue and not a general dns lookup timeout issue.

If I see this problem again and can not find any problem with the dns 
configuration I will turn of the uddi module like David suggested.

As your startup problem seems more frequent I am looking forward to here 
what you find out.

regards
   Peter Petersson

Luis Ortíz Silva wrote:
> I'dont think that the machine are the problem beacuse it has 8 
> processors and 8 GB of ram is a lot of power.
>
> Maybe th JDK is the problem.
>
> 2009/1/6 Donald Woods <dwoods@apache.org <mailto:dwoods@apache.org>>
>
>     Which JDK are you using?  I've seen on occasion when Java SE 6 is
>     used and the server doesn't shutdown cleanly, that all of the JSPs
>     get recompiled on the next startup, which can take 30+ secs
>     depending on the speed of your machine and the apps you have deployed.
>
>
>     -Donald
>
>
>
>     Luis Ortíz Silva wrote:
>
>         Hi:
>
>         I'am getting a big startup issue with mi Geronimo 2.1.3 in
>         Ubuntu Server 8.04 kernel 2.6.24-22-server . It takes 4
>         minutes to start. I start with thi verbose options. But after
>         this message:
>
>         "17:11:53,456 INFO  [SystemProperties] Setting
>         Property=org.apache.catalina.STRICT_SERVLET_COMPLIANCE to
>         Value=true
>
>         Geronimos stops the startup process and delays about 4 minutes
>         in continue.
>
>         I analized the iptables rules, disable the IPv6 capabilities
>         (beacuse Geronimo always binds to an INET6 port), apparmor is
>         desabled, but the problem persist in the time. I reproduced
>         the same error in my laptop, and always did the same.
>
>         If anyone knows how to solve this issue i apreciate a lot,
>         beacuse i need to put in productive mode this server.
>
>


Mime
View raw message