geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Edwin Ansicodd <erik.g.hau...@gmail.com>
Subject Re: Cannot deploy imported Eclipse project to server added to Eclipse
Date Fri, 30 Jan 2009 17:54:57 GMT

Hello Tim,

You mean the geronimo-web.xml?  By JEE5 artifact, you mean the actual EAR
file?

Edwin



Tim McConnell wrote:
> 
> Hi Edwin, yes I expect your Geronimo-specific deployment plans may not
> have 
> gotten converted properly, which would explain the behavior you're seeing.
> Could 
> you email me either your Geronimo deployment plans ?? Or maybe your JEE5
> artifact 
> that you're trying to deploy ??
> 
> Edwin Ansicodd wrote:
>> Hello Tim,
>> 
>> The project does not appear in the list of deployed programs under Web
>> Applications that prints in the console when Geronimo starts up.   
>> Trying
>> to access the url for the project on localhost returns 'The requested
>> resource . . . is not available.'  No error messages appear in the
>> Geronimo
>> server log or the Eclipse workspace log.  
>> 
>> I initially created the project on Eclipse Europa v3.3 with Geronimo v1.1
>> as
>> target server.  I then copied the project to a new workspace and imported
>> it
>> into Eclipse Ganymede v3.4.1 with Geronimo v2.1.3 as target server.  A
>> project still has a Project Facet for Geronimo Deployment 1.1 which I
>> cannot
>> change to v2.1 even though the targeted run time is 2.1.  I wonder if
>> this
>> is preventing it from deploying on 2.1.3?
>> 
>> Thank you,
>> 
>> Edwin
>> 
>> 
>> Tim McConnell wrote:
>>> Hi Edwin, what indication are you getting that it does not deploy ?? Are
>>> you 
>>> getting errors and/or exceptions ?? You might check both the Geronimo
>>> server log 
>>> and the Eclipse workspace log (in the .metadata subdirectory) to see if
>>> there is 
>>> any information that might be useful. If you can't see anything obvious
>>> you can 
>>> export the Proejct and email to me, and I will take a look at it. Thanks
>>> much....
>>>
>>> Edwin Ansicodd wrote:
>>>> Have added Apache Geronimo v2.1 Server to Eclipse Ganymede 3.4.1.  
>>>>
>>>> Right clicking on the server in the server view-> Add and Remove
>>>> Projects, I
>>>> add an existing project that was imported into Eclipse to the Geronimo
>>>> v2.1
>>>> server.  I can start the server, but the Project does not deploy.  In
>>>> the
>>>> server view of Eclipse, the project appears to be configured for the
>>>> server,
>>>> but it is not deploying.  
>>>>
>>>> Any ideas?
>>> -- 
>>> Thanks,
>>> Tim McConnell
>>>
>>>
>> 
> 
> -- 
> Thanks,
> Tim McConnell
> 
> 

-- 
View this message in context: http://www.nabble.com/Cannot-deploy-imported-Eclipse-project-to-server-added-to-Eclipse-tp21687370s134p21752331.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message