geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "thiago.bueno" <thiago.bu...@splicenet.com.br>
Subject Re: Issue with Geronimo and VRaptor
Date Thu, 29 Jan 2009 15:20:15 GMT



Kevan Miller wrote:
> 
> 
> On Jan 29, 2009, at 8:30 AM, thiago.bueno wrote:
> 
>>
>> I’m using Geronimo 2.1.3. Well, I have a Web Java Project with the  
>> frameworks
>> VRaptor 2.5 and Tiles 2.0.6. When I try to upload MyProject.war, I  
>> have the
>> following message from Geronimo console: “Failed to load servlet class
>> org.vraptor.VRaptorServlet”. I did another test changing the order  
>> of the
>> web.xml putting the Servlet Tiles declaration firstly than the  
>> Vraptor’s. So
>> the Geronimo’s console returned to me “Failed to load TilesServlet”.  
>> So I
>> tried to restart the Geronimo Server. Doing this, sometimes I can  
>> upload and
>> sometimes I can’t. I don’t know what’s happening. All the times I  
>> have the
>> same issue message returned. I saw the Log and Geronimo doesn't find  
>> the
>> class VraptorServlet or TilesServlet, but everything is in the  
>> classpath of
>> the project. Could someone help me? Thanks.
> 
> What are the contents of MyProject.war? Are you sure that the Tiles  
> and VRaptor jars are being properly packaged in your war?
> 
> --kevan
> 

In the war I have the classes, the libs(*.jar), i have all the project's
content

Yes, I opened the War of the project and I saw all the jars that i put in my
project... It runs with no errors in GlassFish


-- 
View this message in context: http://www.nabble.com/Issue-with-Geronimo-and-VRaptor-tp21726884s134p21728912.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message