geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lenin David Lozano Argel <ldloz...@avansoft.com>
Subject MDB 3.0 don't consumes Message in Geronimo
Date Thu, 29 Jan 2009 02:23:35 GMT

Hi everyone.

I have an EJB MDB 3.0 using an openejb-jar.xml file to configure
activation-config properties. I use the SendReceiveQueue to send and receive
messages. When I deploy the EJB module in 
http://www.nabble.com/file/p21719689/PruebaMDB3.java PruebaMDB3.java
Geronimo It deploy successfully. But the MDB don't receive any message. I'm
browsing the messages in SendReceiveQueue with Hermes JMS and the messages
are never consumed.

This is my MDB class and the openejb-jar.xml file.

What's wrong with that? I follow the Geronimo and IBM samples and tutorials.

Please help!!!!!!!

<?xml version="1.0" encoding="UTF-8"?>
<ejb:openejb-jar
xmlns:app="http://geronimo.apache.org/xml/ns/j2ee/application-2.0"
xmlns:client="http://geronimo.apache.org/xml/ns/j2ee/application-client-2.0"
xmlns:conn="http://geronimo.apache.org/xml/ns/j2ee/connector-1.2"
xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.2"
xmlns:ejb="http://openejb.apache.org/xml/ns/openejb-jar-2.2"
xmlns:name="http://geronimo.apache.org/xml/ns/naming-1.2"
xmlns:pers="http://java.sun.com/xml/ns/persistence"
xmlns:pkgen="http://openejb.apache.org/xml/ns/pkgen-2.1"
xmlns:sec="http://geronimo.apache.org/xml/ns/security-2.0"
xmlns:web="http://geronimo.apache.org/xml/ns/j2ee/web-2.0.1">
<dep:environment>
<dep:moduleId>
<dep:groupId>default</dep:groupId>
<dep:artifactId>PruebaMDB3</dep:artifactId>
<dep:version>1.0</dep:version>
<dep:type>jar</dep:type>
</dep:moduleId>
<dep:dependencies>
<dep:dependency>
<dep:groupId>org.apache.geronimo.configs</dep:groupId>
<dep:artifactId>activemq-ra</dep:artifactId>
<dep:version>2.1.1</dep:version>
<dep:type>car</dep:type>
</dep:dependency>
</dep:dependencies>
</dep:environment>
<ejb:enterprise-beans>
<ejb:message-driven>
<ejb:ejb-name>PruebaMDB3</ejb:ejb-name>
<name:resource-adapter>
<name:resource-link>ActiveMQ RA</name:resource-link>
</name:resource-adapter>
<ejb:activation-config>
<ejb:activation-config-property>
<ejb:activation-config-property-name>destination</ejb:activation-config-property-name>
<ejb:activation-config-property-value>SendReceiveQueue</ejb:activation-config-property-value>
</ejb:activation-config-property>
<ejb:activation-config-property>
<ejb:activation-config-property-name>destinationType</ejb:activation-config-property-name>
<ejb:activation-config-property-value>javax.jms.Queue</ejb:activation-config-property-value>
</ejb:activation-config-property>
</ejb:activation-config>

</ejb:message-driven>
</ejb:enterprise-beans>
</ejb:openejb-jar>
-- 
View this message in context: http://www.nabble.com/MDB-3.0-don%27t-consumes-Message-in-Geronimo-tp21719689s134p21719689.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message