geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dale <d...@sengsational.com>
Subject Re: Out of memory during second publish - reproduced
Date Thu, 04 Dec 2008 16:03:25 GMT
Thanks Jeff. 

I added -Xmx768M to the end of the existing entry found at:

Run > Run Configurations >  (Geronimo 2.1) >  Arguments > VM Arguments

I started the server right from the run configuration because it seemed
like my -Xmx768M would disappear if I didn't.

It published the second time without error!  I thought I was home-free,
but the third publish, I got a different error:

Connection to deployment manager failed. 
See log for details. Invalid login.

So I tried it all again (many times actually).

I restarted Eclipse, and got the two good publishes, although the
second publish I got this warning:

10:41:20,968 WARN  [ResolverUtil] Could not examine class 
'manning/chapterFour/utils/User.class' due to a 
java.lang.OutOfMemoryError with message: PermGen space

It was just a warning, so the application publish did not
fail.  I removed the project from the server an published
a third time.  This time, the published failed with

10:43:49,250 ERROR [Deployer] Deployment failed due to 
java.lang.OutOfMemoryError: PermGen space

I'm starting Eclipse with "-vmargs -Xmx768M", if that factors into it.
I was unable to change the memory configuration in eclipse.ini without
Eclipse failing to startup, so eclipse.ini contains default settings.

As an additional test, I removed what looked to be the problem,
chapterFour.util, from the project and restarted Eclipse.
After restarting the server from the run configuration with -Xmx768M,
the first publish worked, the second failed with:

Starting of module failed.  See log for details.
  start of default/Struts2InAction/1.0/car failed
  org.apache.geronimo.kernel.config.LifecycleException: start of 
default/Struts2InAction/1.0/car failed

So, the more I play with this, the more different error messages I
seem to be able to expose.

I can work around it by restarting Eclipse for every publish, but that's 
quite a pain. 

Looking for more ideas, I suppose.

--Dale--

RunHua Chi on Tue, 02 Dec 2008 20:38:55 -0800 wrote:

> Changing the eclipse.ini vmargs changes the heap size to run Eclipse, while
> for your application, you might need to change heap size from "Run
> configuration".
>
> Jeff Chi

>>DRS2 Usenet wrote:
(snip)
>> 14) Wait for the application to republish itself.
>> 
>> This is where the error occurs:
>> 
>> Deployment failed due to java.lang.OutOfMemoryError: Java heap space
>> 
>> I've started Eclipse with -vmargs -Xmx768M and get the same result. Not 
>> able to put 1024M in there, for some reason (Eclipse won't even start).



Mime
View raw message