geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim McConnell <tim.mcco...@gmail.com>
Subject Re: Unable to deploy on a remote server in GEP
Date Mon, 01 Dec 2008 23:57:10 GMT
I did not. Once I did it works as expected. Thanks much Donald !!

Donald Woods wrote:
> Did you update the RemoteDeployHostname value in 
> config-substitutions.properties on the remote machine to listen on 
> something besides localhost?
> 
> 
> -Donald
> 
> 
> Tim McConnell wrote:
>> Hi again antoine, looks like there may be a problem. I'm getting a 
>> java.net.ConnectException even after following my own instructions. 
>> I'm pretty sure this used to work, but meanwhile have opened a JIRA 
>> and will investigate. Thanks much for bringing to my attention....
>>
>> -----> https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-537
>>
>> Tim McConnell wrote:
>>> Hi antoine, although the support in the GEP for remote servers is 
>>> very limited, I believe what you are trying to do is valid although 
>>> I'm not exactly sure that you've followed all the necessary steps. 
>>> Here they are briefly:
>>>
>>> 1. First define a local server and make sure it starts within 
>>> Eclipse. If it starts okay, then double-click on the server and 
>>> change the hostname from "localhost" to the remote server's hostname 
>>> or IP.
>>>
>>> 2. Leave Eclipse up and then start the server on the remote system. 
>>> Even though you can't use Eclipse to start/stop the server on the 
>>> remote system Eclipse should still synchronize with the remote 
>>> server. If it does synchronize you will see the status of the server 
>>> in Eclipse change from "Stopped" to *Started". It make take a few 
>>> seconds to synchronize, but then you should be able to deploy to that 
>>> Server.
>>>
>>> 3. Ensure the server on the remote system is still running and then 
>>> try to deploy via Eclipse.
>>>
>>> Can you retry using these steps ?? I'll do the same to ensure it 
>>> still works correctly on my side.....
>>>
>>>
>>> antoine_ wrote:
>>>> Hi,
>>>> I am currently testing Geronimo, but I have problems when trying to 
>>>> deploy
>>>> on a remote server.
>>>> On my local laptop, I run Ubuntu, Java from Sun, Eclipse Ganymede 
>>>> for JEE
>>>> developpers, Geronimo v2.1.3 and I installed the Geronimo Eclipse 
>>>> Plugin by
>>>> following the documentation.
>>>> On the remote server, I have installed Geronimo. I do not see how 
>>>> the plugin
>>>> could start Geronimo remotely, so I start it manually. It works : I can
>>>> access the console, and the launch process tells me that it is 
>>>> listening on
>>>> some ports including 1099 for RMI and 8080 for the console.
>>>>
>>>> In Eclipse, I also succeed to deploy an application locally. It works
>>>> perfectly.
>>>>
>>>> But in Eclipse, the remote server always has the status "stopped". 
>>>> If I try
>>>> an action like "start" or "publish" I get the following error message :
>>>> "Server Apache Geronimo v2.1 Server at 192.168.16.60 failed to start".
>>>>
>>>> There is no firewall between me and the remote server.
>>>>
>>>> I seem to be the only one having such a problem. I did not find 
>>>> anything in
>>>> the documentation about using remote servers. Did I miss something ? 
>>>> Do you
>>>> have any ideas ?
>>>> Thank you...
>>>>
>>>>
>>>
>>
> 

Mime
View raw message