geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rdomingo ...@domingo.nl>
Subject Geronimo Spring 2.5
Date Wed, 03 Dec 2008 14:49:41 GMT

Hello,

I'm just st arting to use geronimo, but it seems hard to get it up and
running...

My application deploy's fine to tomcat and to geronimo-jetty6-minimal-2.1.3,
but it doesn't work in geronimo-jetty6-javaee5-2.1.3, Please help

When I deploy to geronimo-jetty6-minimal-2.1.3 all works fine, but I like to
have a management console which I can't use in the minimal version... (see
also my other thread  'can't install console on geronimo jetty 2.1.3
minimal') 

When I deploy to geronimo-jetty6-javaee5-2.1.3I recieve following error:
...
NoSuchMethodError:
org.springframework.beans.factory.xml.XmlReaderContext.getResourceLoader()Lorg/springframework/core/io/ResourceLoader;
...

It seems related to the spring libraries used during runtime...
I tried:
- adding the 2.5.5 spring libs to the repository
- forcing the use of spring 2.5.5 by changing the
artifact_aliases.properties
- tried to remove all spring stuff, but this couldn't be done without
removing the console...

I just can't get it to work... :(

Please help


-- 
View this message in context: http://www.nabble.com/Geronimo-Spring-2.5-tp20814360s134p20814360.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message