geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Doug Reeder <reeder...@gmail.com>
Subject Re: little-g: OpenJPA::Deployer is not fully resolved
Date Sat, 01 Nov 2008 06:58:55 GMT
Thanks!   I tried using the 2.2 repository with 2.1.3, and the 2.1.2  
repository with 2.1.2, but neither worked.   Is there an older version  
of the server and plugin that work together, or would I need to use  
2.2, and if so, is that stable enough to use?


On Oct 31, 2008, at 9:26 PM, Lin Sun wrote:

> Hi,
>
> I think this error indicates that the system is unable to resolve the
> org.apache.geronimo.modules/geronimo-persistence-jpa10-builder//jar
> artifact because there is no version info associated with the
> artifact.
>
> I checked the plugin catalog of 2.1.3 and didn't see the artifact
> version associated with geronimo-persistence-jpa10-builder under
> plugin OpenJPA::Deployer (see
> http://geronimo.apache.org/plugins/geronimo-2.1.3/geronimo-plugins.xml) 
> .
>  However, this issue is fixed with 2.2 trunk's plugin catalog here
> (http://geronimo.apache.org/plugins/geronimo-2.2/geronimo- 
> plugins.xml).
>
> I don't know why the plugin catalogs were generated differently for
> 2.1.3 and 2.2 on this dependency, without digging more into it.
>
> Lin
>
> On Fri, Oct 31, 2008 at 8:11 PM, Doug Reeder <reeder.29@gmail.com>  
> wrote:
>> I've installed a fresh copy of little-g (Jetty) 2.1.3 on an Intel  
>> Mac Mini
>> running OS X 10.5.5 (Java 1.5.0_16).
>>
>> In one terminal, I run bin/start-server, so as to see the log.   
>> Startup
>> proceeds normally, and the message "Geronimo Server started in  
>> 0:00:06.393"
>> appears in the log.
>>
>> In another terminal, I run bin/gsh, and enter the command
>> deploy/list-plugins -rr -r
>> http://geronimo.apache.org/plugins/geronimo-2.1.3/
>> This gives me a list of 114 plugins and offers to install any or  
>> all of
>> them.  I select 79, Geronimo Plugins, OpenJPA :: Deployer (2.1.3),  
>> and get
>> the following messages:
>> Checking for status every 1000ms:
>> Downloading
>> org.apache.geronimo.modules/geronimo-persistence-jpa10-builder//jar
>> Copying org.apache.geronimo.modules/geronimo-persistence-jpa10- 
>> builder//jar
>> to
>> the repository
>> Installation FAILED: Artifact
>> org.apache.geronimo.modules/geronimo-persistence-jpa10-builder//jar  
>> is not
>> fully
>> resolved
>>
>> In the other window, the Geronimo log shows:
>> 19:50:44,848 ERROR [PluginInstallerGBean] Unable to install plugin.
>> java.lang.IllegalArgumentException: Artifact
>> org.apache.geronimo.modules/geronimo-persistence-jpa10-builder//jar  
>> is not
>> fully resolved
>>       at
>> org 
>> .apache 
>> .geronimo 
>> .kernel 
>> .repository 
>> .AbstractRepository.copyToRepository(AbstractRepository.java:157)
>> .
>> .
>> .
>>
>>
>> What do I need to do to "fully resolve" the plugin OpenJPA::Deployer?
>>
>>
>>
>> I get the same error if I install OpenJPA::OpenJPA at the same  
>> time.   I can
>> install OpenJPA::OpenJPA without error, but my webapp is unable to  
>> use JPA.
>>  If I install OpenJPA::OpenJPA and then OpenJPA::Deployer, I get  
>> the same
>> error as above.
>>
>>


Mime
View raw message