geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From yosemite <kmic...@hotmail.com>
Subject Re: WebService on Geronimo 2.1.3 for Mac OS X 10.5.5 using Java 6
Date Wed, 12 Nov 2008 16:23:32 GMT

Kevan,

thank you for your help, increasing the memory made my application to work
(I migrate from MS Windows to Mac OS and from JBoss to Geronimo, probably
too many things at once :-).

So, all the webServices seem to work OK now, thanks to you, but the
exception is still the same:

geronimo.out says:

 [JAXWSTools] Missing
/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/lib. This may be
required for wsgen to run. 
Problem encountered during annotation processing; 
see stacktrace below for more information.
java.lang.ClassCastException: com.sun.tools.apt.mirror.type.ClassTypeImpl
cannot be cast to com.sun.mirror.type.AnnotationType at
com.sun.tools.apt.mirror.declaration.AnnotationMirrorImpl.getAnnotationType(AnnotationMirrorImpl.java:82)
com.sun.tools.jxc.apt.InlineAnnotationReaderImpl.getAllAnnotations(InlineAnnotationReaderImpl.java:71)
...
... this trace for every webService I deploy (I've got 13 webServices with
cca 30 methods each).

This is how I start geronimo: in command line: 
export JAVA_OPTS="-Xmx512m -XX:MaxPermSize=128m"
export
JAVA_HOME=/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/
./geronimo.sh start

then in Eclipse: Add - Remove projects... my app EAR with EJB module with
the webServices

I noticed in your reply you still mention the /lib but I don't have it in my
...1.6.0 folder. 
If I say "set" on command line, I get:

JAVA_HOME=/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/
JAVA_OPTS='-Xmx512m -XX:MaxPermSize=128m'
JRE_HOME=/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/

Thanks for any help
Karel
yosemite
 


Kevan Miller wrote:
> 
> 
> On Nov 11, 2008, at 8:25 AM, yosemite wrote:
> 
>>
>> Hello,
>>
>> I've tested the same application on MS Windows and it works fine  
>> there. The
>> only difference on MS Windows is Geronimo runs using Java 6 JDK (it  
>> blew up
>> with similar error when tried to use just JRE). Looks like I need to  
>> find
>> out what is the JDK concept on Mac OS :-)
> 
> Starting at the beginning...
> 
> First, suggest you set JAVA_HOME as follows (do you have either  
> JRE_HOME or JAVA_HOME set in your environment?):
> 
> export JAVA_HOME=/System/Library/Frameworks/JavaVM.framework/Versions/ 
> 1.6.0/Home/lib/
> 
> Then start geronimo (e.g. bin/geronimo.sh run). Or are you using  
> Eclipse to launch? In which case you'll need to set server properties...
> 
> That should fix your missing tools problem.
> 
> Next, you can try bumping your permgen space to see if that fixes your  
> OutOfMemoryError:
> 
> stop your server
> export JAVA_OPTS="-Xmx512m -XX:MaxPermSize=128m"
> restart your server
> 
> --kevan
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/WebService-on-Geronimo-2.1.3-for-Mac-OS-X-10.5.5-using-Java-6-tp20423322s134p20463773.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message