geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From yosemite <kmic...@hotmail.com>
Subject Re: WebService on Geronimo 2.1.3 for Mac OS X 10.5.5 using Java 6
Date Tue, 11 Nov 2008 13:25:22 GMT

Hello,

I've tested the same application on MS Windows and it works fine there. The
only difference on MS Windows is Geronimo runs using Java 6 JDK (it blew up
with similar error when tried to use just JRE). Looks like I need to find
out what is the JDK concept on Mac OS :-)

Karel




yosemite wrote:
> 
> Hello,
> 
> trying to deploy @Stateless EJB as a @WebService and get the following
> error:
> 
> [JAXWSTools] Missing
> /System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/lib. This may
> be required for wsgen to run.
> [EjbModuleBuilder] JAXWSEJBModuleBuilderExtension.addGBeans() failed:
> Unable to find the service wsdl file
> 
> After creating the /lib folder in Mac OS Java manually it complains about
> missing tools.jar, after adding an empty tools.jar it does deploy 1
> webService OK, but it looks like it is not able to deploy more than one,
> blows up saying
> 
> java.lang.ClassCastException: com.sun.tools.apt.mirror.type.ClassTypeImpl
> cannot be cast to com.sun.mirror.type.AnnotationType and then
> OutOfMemoryError: PermGen space. 
> 
> I cannot see any messages related to my app, also tried to compile and run
> all using Java 5, same problem.
> 
> Thanks for any help
> Karel
> 

-- 
View this message in context: http://www.nabble.com/WebService-on-Geronimo-2.1.3-for-Mac-OS-X-10.5.5-using-Java-6-tp20423322s134p20439455.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message