I had a similar issue.  I added a dependency for jta to the modules/ejb/pom.xml

Try it again w/o your override and see if it works.

Thanks

On Oct 1, 2008, at 10:00 AM, HRito wrote:

Hi!

I've been trying to install the latest svn trunk of DayTrader in my openSUSE 11, without much success.

At first, mvn could not find javax.transaction which I resolved by telling maven about javaee.jar from my java application platform sdk (using something like mvn install:install-file -DgroupId=javax -DartifactId=javax -Dversion=2.1.7 -Dpackaging=jar -Dfile=javaee.jar).

But later on I had another problem which I don't know how to solve:
org.apache.geronimo.framework/jee-specs/2.2-SNAPSHOT/car: LOADING                                                                                                                 
org.apache.geronimo.framework/jee-specs/2.2-SNAPSHOT/car: FAILED: Error starting configuration gbean org.apache.geronimo.framework/jee-specs/2.2-SNAPSHOT/car                     
FINISHED                                                                                                                                                                          

org.apache.geronimo.kernel.config.LifecycleException: load of org.apache.geronimo.framework/geronimo-gbean-deployer/2.2-SNAPSHOT/car failed
        at org.apache.geronimo.kernel.config.SimpleConfigurationManager.loadConfiguration(SimpleConfigurationManager.java:327)            
        at org.apache.geronimo.kernel.config.SimpleConfigurationManager.loadConfiguration(SimpleConfigurationManager.java:280)

<http://pastebin.com/fb8acd4e for the complete dump>
Help would be appreciated.

Hugo Rito