geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: Spring framework
Date Fri, 24 Oct 2008 16:48:39 GMT

On Oct 24, 2008, at 8:13 AM, Ashwill, Steve (Facilities & Services)  
wrote:

> Any plans to upgrade the Spring Framework to the latest version?  We  
> are
> trying to run the latest version of Mule from mulesource as an
> application in the Geronimo container but there are conflicts with the
> Spring Framework versions. Mule is currently running Spring Framework
> 2.5.
>

You could considerably speed the upgrade if you would try building  
geronimo with the upgraded spring version and see if there are any  
obvious problems and if the old spring copy is pulled in by a  
dependency we haven't excluded.

The spring version is in the root pom as a property.  Assuming the  
build succeeds, check the geronimo repo to make sure only the  
specified spring version is included.

Please open a jira with the upgrade request and your results.

Many thanks
david jencks

>
> Thanks,
> Steven Ashwill


Mime
View raw message