geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Warner" <jaw...@gmail.com>
Subject Re: Unable to deploy tomcat app with WADI Cluster
Date Thu, 04 Sep 2008 21:23:11 GMT
Try changing xmlns="http://geronimo.apache.org/xml/ns/j2ee/web-2.0.1" to
xmlns="http://geronimo.apache.org/xml/ns/j2ee/web/tomcat-2.0.1" and let us
know how that works.

On Thu, Sep 4, 2008 at 5:11 PM, Adam Ruggles <a.ruggles@gmail.com> wrote:

>
>
> <?xml version="1.0" encoding="UTF-8"?>
> <web-app xmlns="http://geronimo.apache.org/xml/ns/j2ee/web-2.0.1"
>         xmlns:naming="http://geronimo.apache.org/xml/ns/naming-1.2"
>         xmlns:sys="http://geronimo.apache.org/xml/ns/deployment-1.2">
>    <sys:environment>
>        <sys:moduleId>
>                <sys:groupId>myappgroupId</sys:groupId>
>                                <sys:artifactId>support</sys:artifactId>
>                                <sys:version>1.0</sys:version>
>                                <sys:type>war</sys:type>
>        </sys:moduleId>
>        <sys:dependencies>
>            <dependency>
>                <groupId>console.dbpool</groupId>
>                <artifactId>support</artifactId>
>            </dependency>
>            <dependency>
>                <groupId>awe.antlr</groupId>
>                <artifactId>antlr</artifactId>
>                <version>2.7.6rc1</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>asm</groupId>
>                <artifactId>asm-commons</artifactId>
>                <version>2.2.3</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>asm</groupId>
>                <artifactId>asm</artifactId>
>                <version>2.2.3</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>axis</groupId>
>                <artifactId>axis</artifactId>
>                <version>1.4</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>commons-codec</groupId>
>                <artifactId>commons-codec</artifactId>
>                <version>1.3</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>commons-collections</groupId>
>                <artifactId>commons-collections</artifactId>
>                <version>3.2</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>commons-discovery</groupId>
>                <artifactId>commons-discovery</artifactId>
>                <version>0.4</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.commons-email</groupId>
>                <artifactId>commons-email</artifactId>
>                <version>1.0</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>commons-fileupload</groupId>
>                <artifactId>commons-fileupload</artifactId>
>                <version>1.1.1</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>commons-io</groupId>
>                <artifactId>commons-io</artifactId>
>                <version>1.2</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>commons-lang</groupId>
>                <artifactId>commons-lang</artifactId>
>                <version>2.3</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.compass</groupId>
>                <artifactId>compass</artifactId>
>                <version>2.0.0.rc2</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.dom4j</groupId>
>                <artifactId>dom4j</artifactId>
>                <version>1.6.1</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.ehcache</groupId>
>                <artifactId>ehcache</artifactId>
>                <version>1.4.0</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.fop</groupId>
>                <artifactId>avalon-framework</artifactId>
>                <version>4.2.0</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.fop</groupId>
>                <artifactId>batik-all</artifactId>
>                <version>1.6</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.fop</groupId>
>                <artifactId>fop</artifactId>
>                <version>0.94</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.fop</groupId>
>                <artifactId>xmlgraphics-commons</artifactId>
>                <version>1.2</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.freemarker</groupId>
>                <artifactId>freemarker</artifactId>
>                <version>2.3.8</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.hibernate-annotations</groupId>
>                <artifactId>ejb3-persistence</artifactId>
>                <version>3.3.1.ga</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.hibernate-annotations</groupId>
>                <artifactId>hibernate-annotations</artifactId>
>                <version>3.3.1.ga</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.hibernate-annotations</groupId>
>                <artifactId>hibernate-commons-annotations</artifactId>
>                <version>3.3.1.ga</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.hibernate</groupId>
>                <artifactId>hibernate</artifactId>
>                <version>3.2.6.ga</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.itext</groupId>
>                <artifactId>bcmail-jdk15</artifactId>
>                <version>137</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.itext</groupId>
>                <artifactId>bcpg-jdk15</artifactId>
>                <version>137</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.itext</groupId>
>                <artifactId>bcprov-jdk15</artifactId>
>                <version>137</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.itext</groupId>
>                <artifactId>bctsp-jdk15</artifactId>
>                <version>137</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.itext</groupId>
>                <artifactId>itext</artifactId>
>                <version>2.0.5</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.jaf</groupId>
>                <artifactId>activation</artifactId>
>                <version>1.1.0</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.jakarta-taglibs</groupId>
>                <artifactId>jstl</artifactId>
>                <version>1.1.2</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.jakarta-taglibs</groupId>
>                <artifactId>standard</artifactId>
>                <version>1.1.2</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.jtidy</groupId>
>                <artifactId>jtidy-8.0</artifactId>
>                <version>20060801.131059-3</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.lucene</groupId>
>                <artifactId>lucene-analyzers</artifactId>
>                <version>2.3.2</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.lucene</groupId>
>                <artifactId>lucene-core</artifactId>
>                <version>2.3.2</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.lucene</groupId>
>                <artifactId>lucene-highlighter</artifactId>
>                <version>2.3.2</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.lucene</groupId>
>                <artifactId>lucene-queries</artifactId>
>                <version>2.3.2</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.lucene</groupId>
>                <artifactId>lucene-snowball</artifactId>
>                <version>2.3.2</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.lucene</groupId>
>                <artifactId>lucene-spellchecker</artifactId>
>                <version>2.3.2</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.nekohtml</groupId>
>                <artifactId>nekohtml</artifactId>
>                <version>0.9.5</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.pdfbox</groupId>
>                <artifactId>FontBox</artifactId>
>                <version>0.1.0</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.pdfbox</groupId>
>                <artifactId>PDFBox</artifactId>
>                <version>0.7.3</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.poi</groupId>
>                <artifactId>poi-2.5.1-final</artifactId>
>                <version>20040804</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.poi</groupId>
>                <artifactId>poi-contrib-2.5.1-final</artifactId>
>                <version>20040804</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.poi</groupId>
>                <artifactId>poi-scratchpad-2.5.1-final</artifactId>
>                <version>20040804</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.quartz</groupId>
>                <artifactId>quartz-all</artifactId>
>                <version>1.6.0</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.spring</groupId>
>                <artifactId>spring</artifactId>
>                <version>2.5.1</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.struts</groupId>
>                <artifactId>ognl</artifactId>
>                <version>2.6.11</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.struts</groupId>
>                <artifactId>struts2-core</artifactId>
>                <version>2.0.11</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.struts</groupId>
>                <artifactId>struts2-spring-plugin</artifactId>
>                <version>2.0.11</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.struts</groupId>
>                <artifactId>xwork</artifactId>
>                <version>2.0.4</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.tagsoup</groupId>
>                <artifactId>tagsoup</artifactId>
>                <version>1.2</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.textmining</groupId>
>                <artifactId>tm-extractors</artifactId>
>                <version>0.4</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.wss4j</groupId>
>                <artifactId>wss4j</artifactId>
>                <version>1.5.3</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.xerces</groupId>
>                <artifactId>resolver</artifactId>
>                <version>2.8.1</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.xerces</groupId>
>                <artifactId>xercesImpl</artifactId>
>                <version>2.8.1</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.xerces</groupId>
>                <artifactId>xml-apis</artifactId>
>                <version>2.8.1</version>
>                <type>jar</type>
>            </dependency>
>            <dependency>
>                <groupId>awe.xmlsec</groupId>
>                <artifactId>xmlsec</artifactId>
>                <version>1.4.1</version>
>                <type>jar</type>
>            </dependency>
>        </sys:dependencies>
>        <sys:inverse-classloading />
>    </sys:environment>
>
>
>    <context-root>/support</context-root>
>
>    <tomcat-clustering-wadi/>
>
>    <!-- security settings, if any, go here -->
>    <resource-ref>
>        <ref-name>jdbc/support</ref-name>
>        <resource-link>support</resource-link>
>    </resource-ref>
>
>    <gbean name="SupportLog4jConfiguration"
>
> class="org.apache.geronimo.system.logging.log4j.ApplicationLog4jConfigurationGBean">
>        <attribute name="log4jFile">var/log/support.properties</attribute>
>                        <reference
> name="ServerInfo"><name>ServerInfo</name></reference>
>                </gbean>
>                <!--
>                <gbean name="DirectoryLog4jConfiguration"
>
> class="org.apache.geronimo.system.logging.log4j.ApplicationLog4jConfigurationGBean">
>        <attribute name="log4jResource">WEB-INF/log4j.xml</attribute>
>    </gbean>
>    -->
> </web-app>
>
>
> --
> View this message in context:
> http://www.nabble.com/Unable-to-deploy-tomcat-app-with-WADI-Cluster-tp19318948s134p19320062.html
> Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.
>
>


-- 
~Jason Warner

Mime
View raw message