geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim McConnell <tim.mcco...@gmail.com>
Subject Re: Eclipse Utility Projects with 2.1.2
Date Fri, 12 Sep 2008 01:06:45 GMT
Hi Kory, are you using the Eclipse all-in-one bundle (e.g., 
eclipse-jee-ganymede-win32.zip for windows) ?? I ask since I'm not seeing what 
you are. When I add a new utility and then add it to an EAR project it shows up 
fine in Eclipse in the EAR's "Bundled Libraries" files (either under /lib or not 
depending on how I specify in the EAR's Java EE Project Module Dependencies). It 
exports fine as well, which sounds like that is working fine for you. Also, when 
I select the Java EE Project Module Dependencies for one of my project not 
included in the EAR I get this message: "Selected module is not referenced by any 
EAR or Dynamic Web modules.", which makes sense since it's not. In both cases I'm 
getting the expected results, whereas you are not. Are you getting in error in 
your .log file in the .metadata directory of your workspace ??

Kory Markevich wrote:
> Should we move this into the JIRA?
> 
> I was able to create the Utility Project successfully.  If I export the EAR,
> then Eclipse bundles it correctly into the EAR file (whether it is put into
> the root or the lib directory depends on a setting in the EAR's project.) 
> However inside Eclipse the contents of the project are not being found. 
> Specifically, the project does not appear in the WTP's "EAR Libraries"
> classpath container.
> 
> Here's the confusing part.  We have 3 utility projects (I hadn't noticed
> these before) that were working in 2.0.2 and are still working in 2.1.2.  I
> tried everything I could think of comparing these (which work fine) to the
> one I created above (which doesn't work) and manually modifying files
> outside of Eclipse, etc..  I couldn't get the new one to work no matter what
> I did.  I even cloned one of the working projects, changed it's name, and it
> wouldn't work.  I'll look into this more tomorrow, hopefully something will
> come to me in the meantime.
> 
> I did notice that going to the "Java EE Module Dependencies" page in the
> properties of any project other than the EAR project (including EJB, WEB and
> utility projects) would give a "Could not accept changes" "The currently
> displayed page contains invalid values" error message.  Not sure if this is
> new or not.
> 
> 
> Tim McConnell-2 wrote:
>> Hi Kory, sorry for the misunderstanding. I though you were actually using
>> the 
>> geronimo-service.xml file, when you were in fact just using Java EE
>> Utility 
>> projects. So obviously we erroneously removed support for utility projects
>> having 
>> Geronimo as a target runtime when we removed support for
>> geronimo-service.xml 
>> files (via GERONIMODEVTOOLS-356). This support has been added back. Would
>> you be 
>> able to test it out to ensure it works now for you ?? I've placed the zip
>> on our 
>> unstable site, but you'll have to uninstall your current GEP before
>> unzipping it 
>> into your current installation. Or better yet, you might want to test it
>> with a 
>> new Eclipse installation so we don't adversely impact you yet again.
>> Thanks much 
>> for you help and patience.
>>
>>
> 

-- 
Thanks,
Tim McConnell

Mime
View raw message