geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From aaaaa <aa...@mytrashmail.com>
Subject Re: Caused by: java.lang.NoClassDefFoundError: org/springframework/beans/factory/InitializingBean
Date Sun, 21 Sep 2008 07:38:11 GMT

Hi Tim,
It is working now. so, I guess, it was a different reason why I was getting
this error.
thanks!




Tim McConnell-2 wrote:
> 
> Hi aaaaa, that should normally work assuming you have the <hidden-classes>
> tag in 
> your geronimo-web.xml deployment plan and your spring jars are in the
> web-inf/lib 
> subdirectory. If both conditions are true are you at liberty to email me a 
> non-proprietary version of your war file and I'll see if I can see
> anything else 
> that might be specified incorrectly ??
> 
> aaaaa wrote:
>> hi all,
>> I'm trying to run web app under geronimo..
>> I'm getting this error , but I have all spring libraries in web-inf/
>> 
>> Caused by: java.lang.NoClassDefFoundError:
>> org/springframework/beans/factory/InitializingBean
>> 
>> I tried this:
>>          <dep:hidden-classes>
>>             <dep:filter>org.springframework</dep:filter>
>>         </dep:hidden-classes>
>> but it didn t help either. 
>> 
>> geronimo 2.1.1.
>> How do I fix it?
>> thanks.
>> 
> 
> -- 
> Thanks,
> Tim McConnell
> 
> 

-- 
View this message in context: http://www.nabble.com/Caused-by%3A-java.lang.NoClassDefFoundError%3A-org-springframework-beans-factory-InitializingBean-tp19552625s134p19592244.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message