geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: org.apache.activemq.store.jdbc.JDBCPersistenceAdapterGBean
Date Sun, 07 Sep 2008 20:13:08 GMT

On Sep 7, 2008, at 12:11 PM, aaaaa wrote:

>
> hi all,
> what jar contains
> org.apache.activemq.store.jdbc.JDBCPersistenceAdapterGBean?
> I'm trying to create a broker with jdbc pers. and I get error:
> couldn't load  
> org.apache.activemq.store.jdbc.JDBCPersistenceAdapterGBean...
>

What makes you think this class exists?  I wonder if it was in a very  
early version of activemq and was removed when we moved all the gbean  
wrappers to geronimo.

Since BrokerServiceGBeanImpl has a reference to a datasource I and  
since kaha didn't really work in amq 4 I think that our default setup  
uses jdbc persistence, so I'd expect all you'd need to do was change  
the reference to the datasource of your choice.  I could well be  
missing the point however.

If you want to do anything more complicated than is demonstrated in  
our activemq-broker plan IMO you should use the more-native  
[xbean-]spring activemq configuration.

thanks
david jencks


> thanks.
>
> -- 
> View this message in context: http://www.nabble.com/org.apache.activemq.store.jdbc.JDBCPersistenceAdapterGBean-tp19359611s134p19359611.html
> Sent from the Apache Geronimo - Users mailing list archive at  
> Nabble.com.
>



Mime
View raw message