geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Bohn <joe.b...@earthlink.net>
Subject Re: Problem building 2.1.2 samples
Date Sun, 24 Aug 2008 00:14:30 GMT

Peter,

The samples are a little in flux at the moment but they should build.  I 
just started with a fresh checkout and clean repo and they built for me.

What version of maven are you using?  It is strange that the versions 
are not specified in /repository/pom.xml ... but I don't hit the same 
errors (perhaps because there is only one version available for each 
from the referenced repository).  BTW, you no longer need to pull the 
repository from geronimo server 2.1.2 since the tag is referenced in the 
/repository/pom.xml.

Please be sure that you have the latest source (svn up) and try mvn 
clean then mvn from the top level. If you still get the error we'll have 
to dig a little deeper.

Joe



Peter Petersson wrote:
> Hi
> 
> I checked out 
> https://svn.apache.org/repos/asf/geronimo/samples/branches/2.1 and
> https://svn.apache.org/repos/asf/geronimo/server/tags/2.1.2/repository
> After installing the G "private" artifacts i run mvn install in the 
> samples top level directory but got a maven validation error.
> It seem like there are a missing dependencyManagement section somewhere 
> along the way originating from the repository pom (see below).
> 
> Am I missing something or are the samples in a flux at the moment ?
> 
> .../gsamples-2.1$ mvn install
> [INFO] Scanning for projects...
> [INFO] 
> ------------------------------------------------------------------------
> [ERROR] FATAL ERROR
> [INFO] 
> ------------------------------------------------------------------------
> [INFO] Error building POM (may not be this project's POM).
> 
> 
> Project ID: org.apache.geronimo.samples:repository
> POM Location: /usr/local/proj/gsamples-2.1/repository/pom.xml
> Validation Messages:
> 
>    [0]  'dependencies.dependency.version' is missing for 
> org.apache.tomcat:catalina
>    [1]  'dependencies.dependency.version' is missing for 
> org.apache.tomcat:jasper
>    [2]  'dependencies.dependency.version' is missing for 
> com.sun.xml.ws:jaxws-tools
>    [3]  'dependencies.dependency.version' is missing for 
> com.sun.xml.ws:jaxws-rt
>    [4]  'dependencies.dependency.version' is missing for 
> org.apache.ant:ant-launcher
> 
> 
> Reason: Failed to validate POM for project 
> org.apache.geronimo.samples:repository at 
> /usr/local/proj/gsamples-2.1/repository/pom.xml
>   :
>   :
> 
> regards
>   peter petersson
> 


Mime
View raw message