geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim McConnell <tim.mcco...@gmail.com>
Subject Re: a problem deploying on geronomino v2.1
Date Sat, 23 Aug 2008 14:37:45 GMT
Hi sserv, did you recently upgrade the version of the Geronimo Eclipse Plugin 
that you use ?? That's the only way I can think that you might start getting this 
message. In any case, though it's relatively simple to convert your project 
deployment version from 1.1 to 1.2. Just change the namespaces in your 
geronimo-specific deployment plans. For example change:

http://geronimo.apache.org/xml/ns/deployment-1.1 -----> 
http://geronimo.apache.org/xml/ns/deployment-1.2
http://geronimo.apache.org/xml/ns/j2ee/application-1.2 	-----> 
http://geronimo.apache.org/xml/ns/j2ee/application-2.0
http://geronimo.apache.org/xml/ns/j2ee/application-client-1.1	----> 
http://geronimo.apache.org/xml/ns/j2ee/application-client-2.0
htttp://geronimo.apache.org/xml/ns/j2ee/connector-1.1	-----> 
http://geronimo.apache.org/xml/ns/j2ee/connector-1.2
http://geronimo.apache.org/xml/ns/j2ee/web-2.0	-----> 
http://geronimo.apache.org/xml/ns/j2ee/web-2.0.1
http://geronimo.apache.org/xml/ns/naming-1.1	-----> 
http://geronimo.apache.org/xml/ns/naming-1.2
http://geronimo.apache.org/xml/ns/security-1.2	-----> 
http://geronimo.apache.org/xml/ns/security-2.0
http://www.openejb.org/xml/ns/pkgen-2.0	-----> 
http://openejb.apache.org/xml/ns/pkgen-2.1

I would be interested in viewing your .log file in your .metadata directory of 
your Eclipse workspace if you could attach it. Please let me know how this works 
our for you. And if you need additional assistance just email me your Eclipse 
projects and I'll convert them for you. Thanks


sserv wrote:
> Hi,
> 
> I was using geronimo v2.1 with tomcat fine for few months fine. Suddenly,
> something went wrong with my project settings and now it is not deploying.
> It says
> 
> "Project facet Geronimo Deployment version 1.1 is not supported."
> 
> If I create a fresh project, it shows a deployment version 1.2. I don't know
> how to convert my project from deployment version 1.1 to 1.2. The UIs
> (project facets in project properties) is not allowing me to do that.
> 
> Please help.
> 
> Geronimo v2.1
> Java 1.5
> Eclipse 3.3.2

-- 
Thanks,
Tim McConnell

Mime
View raw message