geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From devdev <quoc...@yahoo.com>
Subject DB pool from admin console looks wrong
Date Fri, 22 Aug 2008 17:57:51 GMT

Hi all,

I get this deploy plan from the admin console and it looks incomplete to me. 
In the connection section it only list the database name, username and
password.  Without a hostname+port or some connection URL, i don't see how
it can ma the proper connection

Thanks
JFR

<?xml version="1.0" encoding="UTF-8"?>
<connector xmlns="http://geronimo.apache.org/xml/ns/j2ee/connector-1.2">
    <dep:environment
xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.2">
        <dep:moduleId>
            <dep:groupId>console.dbpool</dep:groupId>
            <dep:artifactId>db.pool</dep:artifactId>
            <dep:version>1.0</dep:version>
            <dep:type>rar</dep:type>
        </dep:moduleId>
        <dep:dependencies>
            <dep:dependency>
                <dep:groupId>mysql</dep:groupId>
                <dep:artifactId>mysql-connector-java</dep:artifactId>
                <dep:version>3.1.12</dep:version>
                <dep:type>jar</dep:type>
            </dep:dependency>
        </dep:dependencies>
    </dep:environment>
    <resourceadapter>
        <outbound-resourceadapter>
            <connection-definition>
               
<connectionfactory-interface>javax.sql.DataSource</connectionfactory-interface>
                <connectiondefinition-instance>
                    <name>db.pool</name>
                    <config-property-setting
name="DatabaseName">MyDBName</config-property-setting>
                    <config-property-setting
name="Password">MyPass</config-property-setting>
                    <config-property-setting
name="UserName">MyUser</config-property-setting>
                    <connectionmanager>
                        <local-transaction/>
                        <single-pool>
                            <max-size>10</max-size>
                            <min-size>0</min-size>
                            <match-one/>
                        </single-pool>
                    </connectionmanager>
                </connectiondefinition-instance>
            </connection-definition>
        </outbound-resourceadapter>
    </resourceadapter>
</connector>
-- 
View this message in context: http://www.nabble.com/DB-pool-from-admin-console-looks-wrong-tp19112554s134p19112554.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message