geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From weberj <webe...@yahoo.com>
Subject Re: Are J2EE 1.4 applications still supported?
Date Fri, 08 Aug 2008 14:20:31 GMT


David Blevins wrote:
> 
> 
> On Aug 7, 2008, at 5:07 AM, weberj wrote:
> 
>>
>> I tried the bank sample (EJB sample application (1.2 Ok) ) from
>> http://cwiki.apache.org/confluence/display/GMOxDOC12/EJB+sample+application+(1.2+Ok)
>> I got it to build (I appended my modified build.xml) with
>> geronimo-jetty6-javaee5-2.1.2
>> but on deploying I got the error below.
>> I guess there is a problem with a deployment descriptor, but shouldn't
>> Geronimo be still compatible to the old ones?
>>
>> Deployment failed:
>> Failed parsing descriptors for module:
>> /projekte/geronimo-jetty6-javaee5-2.1.2/var/temp/geronimo- 
>> deploymentUtil51572.jar
>>
>> Caused by: org.apache.openejb.OpenEJBException: Cannot unmarshall the
>> openejb-jar.xml. Xml content written to:
>> /projekte/geronimo-jetty6-javaee5-2.1.2/var/temp/openejb- 
>> jar-51573.xml:
>> unexpected element (uri:"http://geronimo.apache.org/xml/ns/deployment-1.1 
>> ",
>> local:"environment"). Expected elements are....
> 
> We definitely support those older descriptor formats.  We have some  
> fancy code in there so that if you don't supply the namespace we'll  
> guess it, but looks if the namespace was supplied we assume it's right  
> -- i.e. we assume it's the current namespace.
> 
> Try updating this part of the openejb-jar.xml:
> 
>   xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.1"
> 
> to this:
> 
>   xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.2"
> 
> That should take care of it.
> 
> -David
> 
> 
> 

Thanks, that took care of this error, I also had to add a geronimo-ra.xml
for tranql that was missing in the sample (and formerly was not necessary?).
But in the end the EJB JNDI name could not be looked up by the client, see
separate thread.

Kind of pity that older versions of deployment descriptors break application
compatibility, couldn't newer versions of Geronimo still support the old
descriptors?

Juergen


-- 
View this message in context: http://www.nabble.com/Are-J2EE-1.4-applications-still-supported--tp18868952s134p18892698.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message