geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevan Miller <kevan.mil...@gmail.com>
Subject Re: Unable to clear SoftCache field subclassAudits
Date Fri, 25 Jul 2008 16:54:35 GMT

On Jul 25, 2008, at 8:57 AM, lfbarragan wrote:

>
> You were right Kevan, it was the config file... Now it's working but  
> this is
> what happened:
>
> 1) I checked the config folder
> 2) There was no config.xml file, only a config.xml.working file
> 3) I checked the file and it seemed to be ok
> 4) Made copy of the file and renamed it to config.xml
> 5) Executed startup.bat
>
> After all that the server was working again and the  
> config.xml.working file
> was automatically erased.
>
> Do you know why my config.xml file was renamed to config.xml.working?

Good.

So when you update the server's configuration, the processing goes  
something like this:

1. Write new configuration to a temporary configuration file (i.e.  
'config.working')
2. Move current configuration file to the backup file (equivalent to  
'rm config.bak ; mv config.xml config.bak'
3. Rename the temporary configuration file to be the configuration  
file (i.e. 'mv config.working config.xml')

It sounds like a problem occurred between steps 2 and 3. If step 3  
failed, you should have seen some dire warning:

EXTREMELY CRITICAL!  Unable to move manageable attributes working file  
to proper file name!  Configuration will revert to defaults unless  
this is manually corrected!  (could not rename var/config/ 
config.working to var/config/config.xml)

A little misleading, since you won't revert to defaults (as you  
discovered ;-)

If you have any ideas on what might have gone wrong, let us know.

--kevan



Mime
View raw message