geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevan Miller <kevan.mil...@gmail.com>
Subject Re: JCA Connector and hidden-classes
Date Tue, 08 Jul 2008 17:26:05 GMT

On Jul 8, 2008, at 9:24 AM, johnxmas wrote:

> David,
>
> At last, my mail problems are over !
>
> I tried the given solution by adding, in geronimo.bat,
> set GERONIMO_OPTS=%GERONIMO_OPTS% "- 
> DXorg.apache.geronimo.kernel.config.MPCLSearchOption=safe"
>
> It did not solve the problem. Is my syntax correct ?
>
> I tried almost everything, added commons-logging1.1 in the  
> repository and a dependency in my
> deployment plan, and so on...  Still same result: all I'm getting as  
> LogFactory is loaded
> from /D:/geronimo-tomcat6-jee5-2.0.2/lib/commons-logging-1.0.4.jar
>
> I saw aJ Jira was opened for this issue (GERONIMO-4082), but it  
> seems to be still unresolved
>
> I m a bit lost, as I really do need to control my apps logging...

Hmm. The MPCLSearchOption is working for me. I set as follows:

set JAVA_OPTS=-DXorg.apache.geronimo.kernel.config.MPCLSearchOption=safe

I verified that this works on Windows (and Mac OS X). I had Jetty  
installed. Don't see how a Tomcat install could behave differently.

Here's the output during deploy:

MockAdapter setting hostName - Log factory is  
org.apache.commons.logging.LogFactory - loaded from file:/C:/geronimo- 
jetty6-jee5-2.0.2/repository/mock/jca/MockAdapter/1.0/ 
MockAdapter-1.0.rar/rar/commons-logging.jar

Doh... I bet the " " 's that you used are wrong... If you update your  
GERONIMO_OPTS setting in geronimo.bat and remove the quotation mark  
characters, I bet it works...

Still need to fix this properly...

--kevan


Mime
View raw message