geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luciano Salotto" <lsalo...@gmail.com>
Subject Re: NullPointerException "Could not publish to Server" from Eclipse
Date Thu, 31 Jul 2008 11:43:58 GMT
On Thu, Jul 31, 2008 at 8:33 AM, Ziplies <insanitydesign@yahoo.de> wrote:

>
> Hi,
>
> I am currently having the exact same problem as described here. Of course I
> read and tried everything with Java5 but nothing changed. The only
> difference I have is that I use Eclipse Ganymede with GEP2.1.1.
> Referencing the Server, geronimo-tomcat.2.1.1, works fine. It starts, I can
> access it, the console, everything wonderful.
>
> But if I create a dynweb-project it does not create the geronimo-web.xml
> and
> throws NullPointerExceptions if I try to deploy to the server, even if if
> create the geronimo-web.xml myself.
>
> From this thread
http://www.nabble.com/GEP%3A-NullPointerException-when-deploying-project-tp18052894s134p18052894.html

I can tell you that the GEP is not supported for Ganymede.


> I tried to be clever and downloaded and extracted eclipse 3.3.2. Installed
> WTP and so on over the Update Sites and wanted to again create a DynWeb
> Project. But the same thing happened. No geronimo-web.xml but Server gets
> connected correctly and starts and everything.
>
> I tried several Eclipse Versions, clean installs, clean workspaces, no old
> plugins, metadata or configurations. I hope anybody can help me, because I
> am trying for three days know and my nerves are on the bring of collapse.
>

I don't know what's wrong with that, but I got Eclipse IDE for J2EE devs
(you can download it here:
http://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/europa/winter/eclipse-jee-europa-winter-win32.zip
I got it working with the WAS CE Plugin (basically the same as GEP) and I
got no problems at all.


> I thank anyone in advance. If more information is needed, just ask!
>

> Regards
>

Hope this helps

Luciano

Mime
View raw message