Ya, Its a standalone client in Java 5. I have added all the jar's from the directory org/apache/axis2 in geronimo installation directory. Now its throwing me a new error

Exception in thread "main" java.lang.NoClassDefFoundError: javax/wsdl/xml/WSDLLocator
    at org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContextFromFileSystem(ConfigurationContextFactory.java:180)
    at org.apache.axis2.jaxws.ClientConfigurationFactory.getClientConfigurationContext(ClientConfigurationFactory.java:49)
    at org.apache.axis2.jaxws.description.impl.DescriptionFactoryImpl.createServiceDescription(DescriptionFactoryImpl.java:74)
    at org.apache.axis2.jaxws.description.DescriptionFactory.createServiceDescription(DescriptionFactory.java:69)
    at org.apache.axis2.jaxws.spi.ServiceDelegate.<init>(ServiceDelegate.java:87)
    at org.apache.axis2.jaxws.spi.Provider.createServiceDelegate(Provider.java:45)
    at javax.xml.ws.Service.<init>(Service.java:36)
    at javax.xml.ws.Service.create(Service.java:88)
    at abc.CalculatorClient.main(CalculatorClient.java:25)

What could be possibly going wrong?

On Fri, Jun 6, 2008 at 8:04 PM, Jarek Gawor <jgawor@gmail.com> wrote:
That's a standalone client on Java 5, right? You will need to add a
bunch of Axis2 (or CXF depending which engine you want to use) jars to
the classpath. For example, for Axis2 you will need to add
axis2-jaxws-*.jar, axis2-kernel-*.jar, axis2-saaj-*.jar, and a bunch
of others jars.
Also, if possible, you could try running the client on Java 6 and not
worry about Axis2 or CXF jars since Java 6 has JAX-WS engine built-in.

Jarek

On Fri, Jun 6, 2008 at 3:41 AM, sainath chowdary
<sainathdreams@gmail.com> wrote:
> hi,
>
> I have the following code in my java class which basically is trying to
> access the webservice deployed.
> -->URL url = new
> URL("http://localhost:8080/jaxws-calculator-1.0/calculator?wsdl");
>    QName qname = new QName("http://jws.samples.geronimo.apache.org",
> "Calculator");
>    Service service = Service.create(url, qname);
>
> But when i try to run it is a java applicaton I get the following error:
> Exception in thread "main"
> javax.xml.ws.spi.FactoryFinder$ConfigurationError: Provider
> org.apache.axis2.jaxws.spi.Provider not found
>     at javax.xml.ws.spi.FactoryFinder$2.run(FactoryFinder.java:138)
>     at javax.xml.ws.spi.FactoryFinder.doPrivileged(FactoryFinder.java:267)
>     at javax.xml.ws.spi.FactoryFinder.newInstance(FactoryFinder.java:125)
>     at javax.xml.ws.spi.FactoryFinder.access$200(FactoryFinder.java:44)
>     at javax.xml.ws.spi.FactoryFinder$3.run(FactoryFinder.java:258)
>     at javax.xml.ws.spi.FactoryFinder.doPrivileged(FactoryFinder.java:267)
>     at javax.xml.ws.spi.FactoryFinder.find(FactoryFinder.java:168)
>     at javax.xml.ws.spi.Provider.provider(Provider.java:32)
>     at javax.xml.ws.Service.<init>(Service.java:36)
>     at javax.xml.ws.Service.create(Service.java:88)
>     at abc.CalculatorClient.main(CalculatorClient.java:25)
>
> But, when I use the same code to access a web service from a servlet it
> works fine..
> Dont know where i am going wrong. Do we need to specify any other details?
> Kindly clarify me in this regard
>
> --
> Sainath Chowdary
> B.Tech III yr, Spring Semester
> Electronics & Communication Engg
> Indian Institute of Technology Roorkee



--
Sainath Chowdary
B.Tech III yr, Spring Semester
Electronics & Communication Engg
Indian Institute of Technology Roorkee