geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: request.isUserInRole("some-role") always return false after @EJB injection
Date Mon, 16 Jun 2008 17:32:29 GMT

On Jun 16, 2008, at 10:12 AM, Kevan Miller wrote:

>
> On Jun 16, 2008, at 7:57 AM, Stig Even Larsen wrote:
>
>> I forgot to tell that I'm using Geronimo 2.0.2 on Debian Etch.
>>
>> Regards,
>> Stig Even Larsen
>>
>>
>>
>>
>> Stig Even Larsen wrote:
>>> Hi,
>>> After logging in via the j_security_check form I use the simplest  
>>> of jsp  page for testing purpose. I've defined several roles and  
>>> am able to check this via request.isUserInRole("some-role").  
>>> Everything is working as expected.
>>> When I throw in a EJB via @EJB annotation or via JNDI lookup  
>>> request.isUserInRole("some-role") is now always returning false.
>>> Is this a bug or I'm I missing something here?
>
> Hi Stig,
> I think you've run into a bug, which was recently fixed (revision  
> number 663484 for branches/2.0).
>
> The nightly build of 2.0.3-SNAPSHOT should contain the fix. You'll  
> find some binaries here -- http://people.apache.org/builds/geronimo/server/binaries/2.0/20080616/

Just for tracking purposes this is GERONIMO-4099.  This was the bug  
that came to my mind first also, but I'm not convinced it's the same  
problem.  Please let us know whether the 2.0.3 snapshot fixes the  
problem you are seeing.

thanks
david jencks

>
>
> --kevan


Mime
View raw message