geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim McConnell <tim.mcco...@gmail.com>
Subject Re: NullPointerException "Could not publish to Server" from Eclipse
Date Mon, 30 Jun 2008 13:44:05 GMT
Hello everyone, after working with Dave off-line over the weekend we discovered 
that he was using Java 1.6 instead of Java 1.5. Once he switched to Java 1.5 the 
GEP starting functioning as designed. It seems that we can probably be more clear 
about this in our GEP documentation. For example, we say that we prereq Java 1.5, 
but we don't explicitly state that we do not yet support Java 1.6. I shall open a 
documentation JIRA to make these changes. Thanks everyone for assisting......

Dave Syer wrote:
> I can't start any web apps from Eclipse (Europa + GEP 2.1.1).  Even a basic
> HelloWorld application created from File->New... has the same problem.  An
> error shows up in Eclipse's errors view:
> 
> java.lang.NullPointerException
> 	at
> org.apache.geronimo.st.core.internal.DependencyHelper.getEnvironment(DependencyHelper.java:353)
> 	at
> org.apache.geronimo.st.core.internal.DependencyHelper.reorderModules(DependencyHelper.java:97)
> 	at
> org.apache.geronimo.st.core.GeronimoServerBehaviourDelegate.publishModules(GeronimoServerBehaviourDelegate.java:216)
> 	at
> org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publish(ServerBehaviourDelegate.java:669)
> 	at org.eclipse.wst.server.core.internal.Server.doPublish(Server.java:887)
> 	at org.eclipse.wst.server.core.internal.Server.publish(Server.java:874)
> 	at
> org.eclipse.wst.server.core.internal.PublishServerJob.run(PublishServerJob.java:72)
> 	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
> 
> 
> Anyone know where that comes from?  How to fix it?
> 
> The server is running (I can visit its home page and log into the admin
> console and everything).

-- 
Thanks,
Tim McConnell

Mime
View raw message