geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim McConnell <tim.mcco...@gmail.com>
Subject Re: NullPointerException "Could not publish to Server" from Eclipse
Date Sat, 28 Jun 2008 16:11:02 GMT
Hi again Dave, I'm trying to understand why the wizards are not creating the 
Geronimo deployment plans automatically for you. Do you have something other than 
the GEP and the eclipse-jee-europa zip file in your Eclipse installation ?? Does 
the Geronimo server you have defined in the GEP start okay ?? And finally, are 
you using that as the "Target Runtime" when you create your project with those 
wizards (e.g., dynamic-web application) ??

Dave Syer wrote:
> Tim,
> 
> I have the Eclipse version downloaded from the link posted earlier in this
> thread.  It looks like it has all the JEE stuff (file downloaded was
> eclipse-jee-europa-winter-win32.zip - I tried on Linux as well, where
> obviously the filename is different).
> 
> Attached is a dynamic web project created from the wizard (foo.zip).  The
> GEP facet was attached, but no deployment descriptor is present.  It
> probably doesn't tell you much.
> 
> I did get another web app to deploy by copying your deployment descriptor
> verbatim.  The GEP editor still didn't work on it (opened but not editable),
> but at least the app worked.
> 
> Can you do the same magic now for an openejb-jar.xml (also not created by
> the wizard).  I copied one from the samples in trunk, but that didn't work -
> same symptoms as the web case (cannot open in GEP, and NPE when it deploys).
> 
> Thanks,
> 
> Dave.
> 
> 
> Tim McConnell-2 wrote:
>> Hi Dave, that message is benign. Would you be able to export your project
>> from 
>> Eclipse and attach it (or email it to me) ?? Also, do you have the Eclipse
>> prereq 
>> for the GEP (i.e.,  Eclipse IDE for Java EE Developers) ??
>> http://www.nabble.com/file/p18171886/foo.zip foo.zip 
>>
> 

-- 
Thanks,
Tim McConnell

Mime
View raw message