geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim McConnell <tim.mcco...@gmail.com>
Subject Re: NullPointerException "Could not publish to Server" from Eclipse
Date Sat, 28 Jun 2008 15:14:35 GMT
Hi Dave, that message is benign. Would you be able to export your project from 
Eclipse and attach it (or email it to me) ?? Also, do you have the Eclipse prereq 
for the GEP (i.e.,  Eclipse IDE for Java EE Developers) ??

Dave Syer wrote:
> Thanks Tim, that got me started, at least.  Still can't deploy my
> application, so don't go away!
> 
> Updating the namespace as below means that I can open the descriptor with
> the GEP editor.  But nothing I do to it seems to change the source code, so
> I'm not convinced it actually works yet.  The wiki is out of date I guess
> because it shows version 1.0 of the schemas being used.  So I wasn't using
> an invalid namespace (I even downloaded the schema to see if it told me
> anything), just the wrong one.  I guess the tooling could do a better job of
> telling me what's going on there.
> 
> As far as creating a new project, I won't attach anything because there is
> only one entry (and it's a warning not an error):
> 
> "More than one declaration found for action type INSTALL of projet facet
> org.apache.geronimo.facet 1.2."
> 
> Does that mean anything?
> 
> What about adding descriptors to existing projects.  Shouldn't there be a
> New->... menu for it or something?
> 
> Dave.
> 
> 
> Tim McConnell-2 wrote:
>> Hi Dave, actually that is significant. It means that one (or more) of the 
>> namespaces in your deployment descriptor is not valid. If you're using a
>> simple 
>> dynamic web app, the namespaces at the top of the geronimo-web.xml should
>> look 
>> something like this:
>>
>> <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
>> <web:web-app xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.2"
>> 			xmlns:web="http://geronimo.apache.org/xml/ns/j2ee/web-2.0.1">
>>      <dep:environment>
>>          <dep:moduleId>
>>              <dep:groupId>default</dep:groupId>
>>              <dep:artifactId>test</dep:artifactId>
>>              <dep:version>1.0</dep:version>
>>              <dep:type>car</dep:type>
>>          </dep:moduleId>
>>      </dep:environment>
>>      <web:context-root>/test</web:context-root>
>> </web:web-app>
>>
>> Also, the fact that you're not getting a geronimo-web.xml automatically is 
>> problematic. Could you attach the .log file from your workspace .metadata 
>> directory so we can see if you're getting any exceptions. Thanks
>>
> 

-- 
Thanks,
Tim McConnell

Mime
View raw message