geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Syer <david_s...@hotmail.com>
Subject NullPointerException "Could not publish to Server" from Eclipse
Date Fri, 27 Jun 2008 14:03:55 GMT

I can't start any web apps from Eclipse (Europa + GEP 2.1.1).  Even a basic
HelloWorld application created from File->New... has the same problem.  An
error shows up in Eclipse's errors view:

java.lang.NullPointerException
	at
org.apache.geronimo.st.core.internal.DependencyHelper.getEnvironment(DependencyHelper.java:353)
	at
org.apache.geronimo.st.core.internal.DependencyHelper.reorderModules(DependencyHelper.java:97)
	at
org.apache.geronimo.st.core.GeronimoServerBehaviourDelegate.publishModules(GeronimoServerBehaviourDelegate.java:216)
	at
org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publish(ServerBehaviourDelegate.java:669)
	at org.eclipse.wst.server.core.internal.Server.doPublish(Server.java:887)
	at org.eclipse.wst.server.core.internal.Server.publish(Server.java:874)
	at
org.eclipse.wst.server.core.internal.PublishServerJob.run(PublishServerJob.java:72)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)


Anyone know where that comes from?  How to fix it?

The server is running (I can visit its home page and log into the admin
console and everything).
-- 
View this message in context: http://www.nabble.com/NullPointerException-%22Could-not-publish-to-Server%22-from-Eclipse-tp18155922s134p18155922.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message