geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tim Harsch" <thar...@mail.arc.nasa.gov>
Subject RE: Error opening the editor
Date Thu, 19 Jun 2008 20:18:14 GMT
I think I may have found the XML for the geronimo-web.xml I was using off
the web.  However, correcting the namespace did not seem to make a
difference...

-----Original Message-----
From: Tim McConnell [mailto:tim.mcconne@gmail.com] 
Sent: Thursday, June 19, 2008 12:17 PM
To: user@geronimo.apache.org
Subject: Re: Error opening the editor

Hi again Tim, if that is the case, then I totally misunderstood the problem.
If 
you manually add the geronimo-web.xml yourself, just use the correct
namespace as 
below for Geronimo 2.1 as below.....

<web-app xmlns="http://geronimo.apache.org/xml/ns/j2ee/web-2.0.1">
      <environment>
          <moduleId>
              <artifactId>Geronimo2</artifactId>
          </moduleId>
      </environment>
      <context-root>/Geronimo2</context-root>
  </web-app>

One thing we spent a lot of time on in the 2.1 release was to properly
handle the 
current namespaces supported by the Geronimo Server. Unfortunately, it looks
like 
we missed some cases where old namespaces can still be used. For example,
when an 
older namespace is used in a project that is imported into the GEP we
convert it 
on the fly. It looks like though we still need to handle older namespaces
better. 
I think we may have a JIRA already for this problem, but if not I shall open
a 
new one. Thanks very much for the feedback....


Tim Harsch wrote:
> I thought of another detail to add to the problem scenario.  If I create a
> new dynamic web project with Geronimo 2.1, and the open geronimo-web.xml
> file then the Web Deployment Plan editor opens.  However, starting with a
> new Tomcat project and adding a basic geronimo-web.xml file causes the
> problem. 
> 
> -----Original Message-----
> From: Tim Harsch [mailto:tharsch@mail.arc.nasa.gov] 
> Sent: Thursday, June 19, 2008 10:09 AM
> To: user@geronimo.apache.org
> Subject: RE: Error opening the editor
> 
> Hi Tim,
> 	I believe I installed geronimo-tomcat6-javaee5-2.1.1 server and GEP
> 2.1.  Is there a JIRA item for the fixed problem you could point me to for
> background?  Perhaps I can examine further...
> 
> -----Original Message-----
> From: Tim McConnell [mailto:tim.mcconne@gmail.com] 
> Sent: Wednesday, June 18, 2008 9:22 PM
> To: user@geronimo.apache.org
> Subject: Re: Error opening the editor
> 
> Hi Tim, I think you may be using an older version of the Geronimo Eclipse
> Plugin 
> (GEP). This was a problem in the 2.0.0 version of the GEP but has been
fixed
> in 
> the 2.1.0 release. If this is the case, could you try the newer version
and
> let 
> me know what happens ??
> 
> Tim Harsch wrote:
>> Hi all,
>>
>>                I get the following error when trying to open 
>> geronimo-web.xml file:
>>
>>                " There was an error opening the editor.  The elements in 
>> the plan may not be qualified, do you want to try to auto-correct this? 
>> Otherwise the default text editor will be opened."
>>
>>                Googling that phrase gives no love.
>>
>>  
>>
>>                Here's the content of my file:
>>
>> <web-app xmlns="http://geronimo.apache.org/xml/ns/j2ee/web-1.1">
>>
>>     <environment>
>>
>>         <moduleId>
>>
>>             <artifactId>Geronimo2</artifactId>
>>
>>         </moduleId>
>>
>>     </environment>
>>
>>     <context-root>/Geronimo2</context-root>
>>
>> </web-app>
>>
>>  
>>
>> Tim
>>
> 

-- 
Thanks,
Tim McConnell



Mime
View raw message