geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From michaelg <mike...@gmail.com>
Subject Geronimo and Grails
Date Wed, 14 May 2008 04:55:40 GMT

I am writing an article for IBM developerWorks on using Grails and Geronimo
together. However, I am unable to deploy a Grails WAR to Geronimo. 

I first tried it with Geronimo 2.1.1 with Jetty. The error I got was a
NoClassDefFound for org.apache.commons.fileupload.FileItemFactory. This
class is the Geronimo repository, and is also included with the Grails war.
It's the same version for both. 

Next I tried it with Geronimo 2.1.1 with Tomcat. This time I got a dom4j
InvalidXPathException. 

Next I tried the Little G distribution. It worked perfectly. I had also
tried standalone Tomcat with success as well, so I guess this should not
have been too surprising.

Obviously I have to point a finger at Grails or Geronimo, and since it works
fine on Tomcat or Little G, I am pointing the finger at Geronimo. The
Geronimo/Jetty error sure smelled like a class loader problem, but I have no
clue on the Geronimo/Tomcat. Note, in all cases I included a Geronimo
deployment plan inside the WAR (/WEB-INF/geronimo-web.xml) 

Any ideas/advice is greatly appreciated.
-- 
View this message in context: http://www.nabble.com/Geronimo-and-Grails-tp17223357s134p17223357.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message