geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Thorburn" <nzi...@gmail.com>
Subject Re: Geronimo 1.1.1 + ActiveMQ - How do I allow pages to find amq.js?
Date Tue, 29 Apr 2008 22:59:01 GMT
Doh. Should probably have been a bit more specific:

I'm trying to do AJAX stuff (using Javascript), and in order to do some
testing, I need to be able to create a simple page that can be found by an
existing project. So far, not too hard.

The tricky bit is that it uses Geronimo, and I want the project to be able
to find the ActiveMQ implementation. amq.js is the Javascript that allows a
web browser to do AJAX stuff with a JMS queue. This is probably the
important part - I want to use the AJAX functionality of ActiveMQ, and in
order to do that, I need access to the various javascript files that contain
the implementation. Right now, my project can't find them, and thus I'm
kinda stuck.

The exact version of AMQ doesn't matter (right now, anyway), however, the
version of *Geronimo* does - I can't upgrade from 1.1.1 to 2.* because the
project I'm working on has issues with it. As such, 3.4 seems like it would
work just as well as 5.0.0, provided 3.4 has AJAX support. If it doesn't,
then what I'm trying to do will never be successful, and I'm a little
screwed.

I'll keep playing around with the dependencies and see if they'll work for
me.

I hope that makes things a bit clearer with regards to what I'm trying to
do.

Also, while I'm here, if I wanted to use ActiveMQ 5.0.0 (or any version
apart from what's provided), what would that involve for Geronimo 1.1.1?
Would it be a simple matter of adding it to the repository (i.e. click and
drag), or would it be more complex than that?

- Andrew Thorburn

On Wed, Apr 30, 2008 at 5:02 AM, David Jencks <david_jencks@yahoo.com>
wrote:

>
> On Apr 28, 2008, at 6:03 PM, Andrew Thorburn wrote:
>
>  I tried to load up a page (that worked fine when I tested using AMQ 5.0)
> > under Geronimo 1.1.1, and it seems that it can't find amq.js.
> >
> > I know that I had to edit my web.xml file when testing it first time
> > around, but upon doing the same thing, it gave an error that it couldn't
> > find org.apache.activemq.web.AjaxServlet. Is this likely to be a case of me
> > trying to use instructions that are too new?
> >
>
> IIRC Geronimo 1.1.1 includes an AMQ version somewhere around 3.x.  I don't
> know that anyone has succeeded in using AMQ 5 with G. 1.1.1.
>
> >
> >
> > I can't really upgrade as that would cause a large number of problems
> > with the application I'm adding to (I've come in recently and it's quite
> > large), and I don't have time to fix them all.
> >
>
> Even the latest geronimo is still on AMQ 4.1.2....
>
> >
> >
> > The other relevant things are that the project uses Struts (*.do stuff,
> > etc), and I'm not entirely sure how that works.
> >
> > I also tried to add some dependencies to the geronimo-web.xml file, but
> > it decided it didn't like the <exclusion> tags. Removed those, and it went
a
> > bit further: it now says it's "Unable to resolve dependency
> > incubator-activemq/activemq-web//"
> >
>
> that doesn't look much like the id for an existing activemq jar..... are
> you sure it isn't something like org.apache.activemq/activemq-web//?  You
> will also need to get these jars into your geronimo repository yourself
> unless you use a geronimo plugin -- and they don't work well before geronimo
> 2.1.
>
> >
> >
> > Anyone able to give me some help here? Otherwise I've got a bad feeling
> > it'll take a long time to figure this all out by myself.
> >
>
> Do you need AMQ 5? What does the amq.js page do?  Is it included in the
> AMQ version geronimo includes?
>
> More questions for you, but I don't understand exactly what you are trying
> to do yet.
>
> thanks
> david jencks
>
>

Mime
View raw message