geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Thorburn" <nzi...@gmail.com>
Subject Geronimo 1.1.1 + ActiveMQ - How do I allow pages to find amq.js?
Date Tue, 29 Apr 2008 01:03:21 GMT
I tried to load up a page (that worked fine when I tested using AMQ 5.0)
under Geronimo 1.1.1, and it seems that it can't find amq.js.

I know that I had to edit my web.xml file when testing it first time around,
but upon doing the same thing, it gave an error that it couldn't find
org.apache.activemq.web.AjaxServlet. Is this likely to be a case of me
trying to use instructions that are too new?

I can't really upgrade as that would cause a large number of problems with
the application I'm adding to (I've come in recently and it's quite large),
and I don't have time to fix them all.

The other relevant things are that the project uses Struts (*.do stuff,
etc), and I'm not entirely sure how that works.

I also tried to add some dependencies to the geronimo-web.xml file, but it
decided it didn't like the <exclusion> tags. Removed those, and it went a
bit further: it now says it's "Unable to resolve dependency
incubator-activemq/activemq-web//"

Anyone able to give me some help here? Otherwise I've got a bad feeling
it'll take a long time to figure this all out by myself.

Mime
View raw message